Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have been using Ubuntu 13.04 as my primary OS for quite sometime on Sony VAIO laptop with other OS being windows 8 (never use it). Till today, everything was fine.

In the evening I had shut down my PC and closed the lid; Typically I do this when the shutting down screen is still on. But probably this time it was fatal. (The only new thing I installed was video download plugin for Firefox & after that my Ubuntu was working fine till I shut down)

When I again restarted my PC, now no menu is appearing for selecting OS and it directly goes for Windows 8. My question is similar to this thread, but I don't have Ubuntu CD as I had installed using pen drive sometime back.

Is there any (genuine or workaround) easier way to get back the GRUB menu back in the place?
Note that keyboard shortcuts in Sony VAIO is different, here I have an "Assist" menu as well to get those internal options.

Update: Seems to be partition error. Now even stupid Windows 8 is also not coming :( I tried pressing "left shift", but no luck there as well. Writing this from mobile. Need some urgent help.

Still after fixing the grub menu, my Ubuntu has started working, but Windows 8 has gone bad. I am trying few option available in the Internet. Will keep updating those useful links.

  • This link demonstrates the similar problem where Windows 8 is not working in dual boot partition with Ubuntu.
share|improve this question
add comment

1 Answer

up vote 2 down vote accepted

I'm going to assume you have UEFI. You need to enter your UEFI settings (if you haven't already) and do two things.

  1. Make sure secure boot is off
  2. Make sure Ubuntu (or something like that) is above Windows in the boot order. If this doesn't work you should try to get boot-repair. If you can't make a new USB or DVD you might have to buy one.

Boot-repair help/info: boot-repair

I might be able to give more advice as well if the first UEFI settings doesn't work but you can tell me more about what happened when you tried it.

share|improve this answer
    
I tried making secure boot off, but couldn't find the boot order. Presently even Window 8 is also not working. Any way out? –  iammilind Jun 26 '13 at 2:00
    
What does your UEFI settings screen look like? A picture would help. –  zzomtceo Jun 26 '13 at 12:18
    
Anyways, it seems that there is no way other than boot-repair, so I downloaded the 13.04 (64-bit) iso image from Ubuntu website and ran Ubuntu Live using USB. Then installed boot repair on live Ubuntu and fixed the issue. –  iammilind Jun 26 '13 at 15:06
    
So is this allowing Windows to work for you as well? –  zzomtceo Jun 26 '13 at 16:50
    
Unfortunately no. And for so many days, I am trying various options , but no luck. Finally I have posted one more question in this forum. –  iammilind Aug 8 '13 at 5:12
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.