Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have this random network failure. No error pops up, the system says it's still connected to the internet(wifi and wired).
The problem is, I can't connect to anything, even a ping google.com gives no feedback.
This only affects eth0, wifi is still working correctly, the cable and the port are fine.
I know this because when I boot my device, it is connected to the internet, skype logs in, but when I want to open a connection to anything else(browser, vm, ping or whatever) it drops out, saying it is still connected and no errors.

I noticed that the /etc/resolv.conf contains this line:

nameserver 127.0.0.1

I had a random 3 sec connection, after which it dropped out again, and this line was added in the resolv.conf

search lan

When I change the nameserver to 8.8.8.8, I am still unable to connect to anywhere.

Does anyone got a clue what is happening here? I will provide any information asked.

Thanks in advance

p.s. I run Ubuntu 13.04, and started after upgrading from 12.10 to 13.04

share|improve this question
    
You write "When I change the nameserver to 8.8.8.8, I am still able to connect to anywhere." Did you mean to say "I am still UNable to connect"? –  jdthood Jun 28 '13 at 11:27
    
@jdthood woops, yes I meant that –  Dr_Bunsen Jun 28 '13 at 13:32

1 Answer 1

up vote 5 down vote accepted

One known bug that could be affecting you is this: https://bugs.launchpad.net/ubuntu/+source/dnsmasq/+bug/1003842

Try disabling the local forwarding nameserver. In NetworkManager.conf

gksudo gedit /etc/NetworkManager/NetworkManager.conf

or

sudo gedit /etc/NetworkManager/NetworkManager.conf

comment out the line dns=dnsmasq

#dns=dnsmasq

and save the file and restart NetworkManager.

sudo restart network-manager
share|improve this answer
    
Thanks, that fixed it. –  Dr_Bunsen Jun 28 '13 at 13:41
    
Aren't we supposed to use gksudo for graphical things that use sudo? Not that it works differently –  Dr_Bunsen Jun 30 '13 at 19:01
    
The gksu package isn't installed by default. But I will edit the answer to mention it because gksudo seems to be preferred for launching graphical applications with root privs. –  jdthood Jul 1 '13 at 14:42
    
Solved my problem. Thanks. –  Marc Aug 9 '13 at 4:13

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.