Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

So this error has been popping up a lot so I thought I'd resolve it:

W: GPG error: http://cfengine.com precise Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 535C743689107B44

So I did some research and tried these solutions

gpg --keyserver hkp://keyserver.ubuntu.com:80 --recV 535C743689107B44

and

sudo apt-key adv --keyserver.ubuntu.com --recv-keys 535C743689107B44

both of which terminated with this message

gpgkeys: key 535C743689107B44 not found on keyserver
gpg: no valid OpenPGP data found.
gpg: Total number processed: 0

Any insights are appreciated

share|improve this question

2 Answers 2

up vote 1 down vote accepted

Maybe the GPG-key is not there (anymore).

If you want to install CFEngine Community Linux Packages: from(http://cfengine.com/cfengine-linux-distros)

exerpt: CFEngine 3 Linux Distributions: Download and install the CFEngine GPG key(changed # to sudo because of formating):

sudo wget http://cfengine.com/pub/gpg.key

sudo apt-key add gpg.key

sudo rm gpg.key

Add the repository to the apt list of sources. If the add-apt-repository utility is installed on your system, you may simply run:

sudo add-apt-repository http://cfengine.com/pub/apt

... follow instructions on the website.

share|improve this answer

The second approach mentioned in this link worked for me. Manually download the key and add it. The link provides step by step procedure to fix the error happening due to missing key.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.