Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to modify the clock frequencies in nvidia-settings. I have added the Option Coolbits 1 in my /etc/X11/xorg.conf file and restarted gdm, and even my computer.

The options are now available in nvidia-settings, and I can slide the slider up and down, but when I choose "Apply" it simply reverts them back to default. I even tried to run nvidia-settings by way of sudo, and I got the same result.

I also installed nvclock and I am trying to modify clock and fan settings through that command-line utility, but with no avail there either. The fan speed says it is increased to 100% for example, but the fan does not change and nvidia-settings stays stable at 35% fan speed.

I am running 10.10 x86 and Nvidia driver 260.19.06 with a 9600 GT.

share|improve this question

Set option 'CoolBits' to Value 4 in Section 'Screen':

   Option         "CoolBits" "4"

It should look a little something like this:

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "0"
    Option         "CoolBits" "4"
    Option         "TwinViewXineramaInfoOrder" "CRT-0"
    Option         "metamodes" "1280x1024_60 +0+0; 1024x768 +0+0; 800x600 +0+0"
    SubSection     "Display"
        Depth       24

Using this, you will be able to adjust the fan settings (among a few other options in nvidia-settings disabled by default).

Unfortunately, nvclock is unable to handle more recent nVidia GPUs, but nvidia-settings already allows you to set a big amount of the more important options. It worked for me, surely it will work for you to.

share|improve this answer

Option "Coolbits" "1"

Should look like this, not sure whether quotes do it any good but seems to be working in my system with 9500gt.

Also be sure you added it in Section "Screen".

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.