Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am brand new to Ubuntu, after many years with Windows and a dabble with OSX, so please go easy on me. Yesterday, after ruining the pre-installed Windows 8 with the Ubuntu install I had to install my copy of Windows 7, in which I couldn't get any WIFI, so I then erased Windows 7 with Ubuntu 13.04....

I have a couple of questions please.

  1. When I turn on my laptop, I get the Purple screen which lists choices of Ubuntu, and Windows 7 loader, even though Ubuntu erased this on install, and a couple of other choices...How do I completely get rid of that screen, so my Laptop boots straight to Ubuntu, without me having to make a choice?

  2. On my laptop I have Nvidia Graphics card 675m. I tried to install Nvidia drivers via the Software Updater, in 'Additional Drivers', I chose the latest one '313' and '310', both changed the resolution in Ubuntu and make the laptop flash with a crackly black screen on Shutdown and Startup. When I installed the drivers I also could not find any Nvidia control panel.

    So how do I safely install Nvidia drivers? I know there is a long winded install using a Virtual console, which I have never used in my life. Do I have to download the drivers from Nvidia first from their website before doing anything?

Thanks in advance,

D.

share|improve this question
2  
Please don't club multiple question in one thread. Open different thread for each question if they are not related. I am answering the first query. Edit your question to remove second one and recreate another question. It is very difficult to answer all question in one answer. See FAQ. For the second issue, in your new question please include result of lspci –  Web-E Jun 25 '13 at 10:52

1 Answer 1

The windows boot manager resides on a separate small partition (around 100mb). Most probably that partition is not deleted that is why the entry is listed.

There are multiple solution :

  1. Most easy one if you are not installing any other OS :

    • Open a terminal, type sudo gedit /etc/default/grub
    • At bottom add GRUB_DISABLE_OS_PROBER=true (this will disable other os search function)
    • Save and close the file.
    • run sudo update-grub
  2. Change Time for which the menu is shown

    • Open a terminal, type sudo gedit /etc/default/grub
    • Search and Change GRUB_TIMEOUT= value to 0. It will be GRUB_TIMEOUT=0
    • Save and close the file.
    • run sudo update-grub

After doing above if you need grub for some cause (like for booting older kernel), press shift while booting to get GRUB menu

share|improve this answer
    
Thanks for this. How do I run sudo update-grub? Also, do I have to do both these tasks, or one of the two? –  dcooper Jun 25 '13 at 11:14
    
in the same terminal. Any one. First one will do. :) –  Web-E Jun 25 '13 at 11:17

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.