Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Whenever I try and start friends-app, it crashes with the error:

friends-dispatcher crashed with ValueError in raw_decode(): No JSON object could be decoded

I've tried reinstalling but that didn't help. It works fine on another PC (logging in to the same Twitter account), also on 13.04.

The apport error lists the crash as a duplicate of https://bugs.launchpad.net/bugs/1166432, but that just 404s, so I don't know what the underlying issue is.

How do I fix the problem?

Edit: launching from a terminal gives me:

virtual void OnlineAccounts::Plugin::registerTypes(const char*) Ubuntu.OnlineAccounts 
virtual void FriendsPlugin::registerTypes(const char*) Friends 
QQmlComponent: Component is not ready
MODEL:  "com.canonical.Friends.Streams" 
account-service-model.cpp 266 update 
account-service-model.cpp 266 update 
Segmentation fault (core dumped)
share|improve this question

closed as off-topic by Eric Carvalho, Seth, AgentCool, Jorge Castro, Thomas W. Jul 6 '13 at 16:10

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Bug reports should be submitted via Launchpad so that the developers are made aware of them. See: How do I report a bug?" – Eric Carvalho, Seth, AgentCool, Jorge Castro, Thomas W.
If this question can be reworded to fit the rules in the help center, please edit the question.

    
What happens when you launch friends from a terminal? Can you give the output of that? Are you perhaps behind a firewall? –  Gx1sptDTDa Jul 1 '13 at 14:27
    
I've edited my question to include the terminal output (basically, segfault). The other machine it works on is on the same network, so I don't think there's a networking issue. –  Tim Fountain Jul 1 '13 at 14:57
    
I think you are missing some dependencies. This is crazy and impractical but try sudo apt-get update && sudo apt-get install ubuntu-sdk && sudo apt-get upgrade –  leszakk Jul 2 '13 at 0:25
    
Thanks, that installed a whole load of stuff, but I still get the same error from friends-app. –  Tim Fountain Jul 2 '13 at 8:57

1 Answer 1

up vote 0 down vote accepted
+50

This look like a confirmed bug.

Friends app crashes instantly when loading.

Steps to reproduce:
Run friends app from the terminal, or click the "Friends" logo in the dash.

Expected Behavior:
Friends app displays timeline.

Actual behavior:

Friends app never comes up. If run from the terminal, the "Segmentation Fault" message is seen.

See Friends app crashes on start

Source:Launchpad

share|improve this answer
    
Thanks, looks like this does cover the same issue even though it's a different bug report to the one mentioned in my apport report. The comments there suggest the bug has been fixed in an upcoming version, so I'll hold out for that. –  Tim Fountain Jul 4 '13 at 8:21

Not the answer you're looking for? Browse other questions tagged or ask your own question.