Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

I was trying to run minecraft on my laptop with ubuntu 12.04 lts 64 bit. I have a lenovo ideapad p580 with 7.7 Gb and an Intel® Core™ i7-3520M CPU @ 2.90GHz × 4 processor. Under the graphics section of the system overview in ubuntu it says I have none installed. My computer comes with and nvidia geforce graphics card but it isnt recognized. When I start minecraft I get this crash report.

---- Minecraft Crash Report ----
// Shall we play a game?

Time: 24/06/13 7:23 PM
Description: Failed to start game

org.lwjgl.LWJGLException: Could not init GLX
    at org.lwjgl.opengl.LinuxDisplayPeerInfo.initDefaultPeerInfo(Native Method)
    at org.lwjgl.opengl.LinuxDisplayPeerInfo.<init>(LinuxDisplayPeerInfo.java:52)
    at org.lwjgl.opengl.LinuxDisplay.createPeerInfo(LinuxDisplay.java:684)
    at org.lwjgl.opengl.Display.create(Display.java:854)
    at org.lwjgl.opengl.Display.create(Display.java:784)
    at org.lwjgl.opengl.Display.create(Display.java:765)
    at net.minecraft.client.Minecraft.a(SourceFile:235)
    at avv.a(SourceFile:56)
    at net.minecraft.client.Minecraft.run(SourceFile:507)
    at java.lang.Thread.run(Thread.java:679)

A detailed walkthrough of the error, its code path and all known details is as follows:

-- System Details --
Details:
    Minecraft Version: 1.5.2
    Operating System: Linux (amd64) version 3.5.0-34-generic
    Java Version: 1.6.0_27, Sun Microsystems Inc.
    Java VM Version: OpenJDK 64-Bit Server VM (mixed mode), Sun Microsystems Inc.
    Memory: 406175448 bytes (387 MB) / 514523136 bytes (490 MB) up to 1908932608 bytes (1820 MB)
    JVM Flags: 2 total; -Xmx2048M -Xms512M
    AABB Pool Size: 0 (0 bytes; 0 MB) allocated, 0 (0 bytes; 0 MB) used
    Suspicious classes: No suspicious classes found.
    IntCache: cache: 0, tcache: 0, allocated: 0, tallocated: 0
    LWJGL: 2.4.2
    OpenGL: ~~ERROR~~ NullPointerException: null
    Is Modded: Probably not. Jar signature remains and client brand is untouched.
    Type: Client (map_client.txt)
    Texture Pack: Default
    Profiler Position: N/A (disabled)
    Vec3 Pool Size: ~~ERROR~~ NullPointerException: null

I can run it on different versions of linux such as fedora.

share|improve this question

marked as duplicate by Luis Alvarado Jun 25 '13 at 4:17

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

add comment

1 Answer 1

I suspect that your driver could be installed but not in use, have a look in your config file using:

sudo nano /etc/X11/xorg.conf

If your data is not there you may need to add this or similar to this to enable it.

Section "Screen"
Identifier "Default Screen"
DefaultDepth 24
EndSection

Section "Module"
Load "glx"
EndSection

Section "Device"
Identifier "Default Device"
Driver "nvidia"
Option "NoLogo" "True"
EndSection

And then save and in the terminal type:

sudo reboot

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.