Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Last week I bought a AMD E350 (AMD Fusion platform) based Sony VAIO (VPCYB15AG) having AMD Radeon HD 6310 graphics, I removed Windows that came along with and installed Ubuntu 10.10 (AMD64) using USB drive.

During installation my touchpad was not working, I managed through keyboard, but after completing installation & restarting the machine still there was no touchpad support. Also there's no proper graphic card drivers. Even I tried connecting the USB mouse to it but the left key is not working and had to configure the mouse as left-hand to get the left click enabled.

I tried searching for any possible solutions for these but found nothing helpful, is there any hope? What should I do to enable
i) enable touch pad support
ii) get higher resolution 1366x768, etc?

share|improve this question
up vote 2 down vote accepted

For touchpad support :

  1. Open /etc/default/grub in superuser mode and then change the line GRUB_CMDLINE_LINUX="" to GRUB_CMDLINE_LINUX="i8042.reset i8042.nomux i8042.nopnp i8042.noloop"

  2. Run the sudo update-grub command in a terminal.

  3. Restart your machine.

Hopefully, your touchpad should work.

Graphics/Video Card Drivers

  1. Go to System -> Administration -> Additional Drivers

    • You will find graphics driver for ATI/AMD
    • Activate it
    • Restart the machine


  1. Add ubuntu-audio-dev ppa:

    sudo add-apt-repository ppa:ubuntu-audio-dev/ppa
    sudo apt-get update
    sudo apt-get install linux-alsa-driver-modules-$(uname -r)
  2. Reboot machine & check levels in alsamixer by alsamixer. Press to select correct soundcard, show playback level, select capture levels.Use arrow keys to select & change levels, to mute/unmute.

Now go to "System>Preferences>Sound",check correct soundcard is default & adjust profile on the hardware tab.On output tab choose correct device.

Hopefully, you will get your desired resolution.

share|improve this answer
Thanks. It worked like a charm, only hitch was the graphics driver which got installed were for different version of the ATI card and was displaying an "ATI Unsupported Hardware" watermark on the right bottom corner of the screen. So I followed these links to get the correct graphics driver installed. Ubuntu HowTo for ATI, Unofficial Ubuntu forum & AMD Website – Gaurav Mar 21 '11 at 19:33

I tried with 10.10 on the same laptop, it was really hard to get everything to work, so I installed a Windows 7 and when the 11.04 beta 2 came out I installed it, and, Guess What? It works like a charm

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.