Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to install UNetbootin on Ubuntu 12.04 LTS. I downloaded the executable file from this link and followed the instructions below:

If using Linux, make the file executable (using either the command chmod +x ./unetbootin-linux, or going to Properties->Permissions and checking "Execute"), then start the application, you will be prompted for your password to grant the application administrative rights, then the main dialog will appear, where you select a distribution and install target (USB Drive or Hard Disk), then reboot when prompted.\

So I typed on my terminal sudo chmod +x unetbootin-linux-584 and tried to execute the binary file with ./unetbootin-linux-584 but got this output:

./unetbootin-linux-584: error while loading shared libraries: libXrandr.so.2: cannot open shared object file: No such file or directory

However when I checked for libraries libXrandr on my system I actually found them

$> locate libXrandr
/usr/lib/x86_64-linux-gnu/libXrandr.so.2
/usr/lib/x86_64-linux-gnu/libXrandr.so.2.2.0
/usr/lib/x86_64-linux-gnu/libXrandr_ltsq.so.2
/usr/lib/x86_64-linux-gnu/libXrandr_ltsq.so.2.2.0

so I really don't have a clue of what's the problem and how can I fix it, any ideas?

share|improve this question
3  
Have you tried running sudo apt-get install unetbootin in a terminal? –  edwin Jun 24 '13 at 22:39
add comment

1 Answer

up vote 5 down vote accepted

My guess is you are trying to run a 32 bit application on a 64 bit host.

unetbootin is in the repos

http://packages.ubuntu.com/search?keywords=unetbootin

sudo apt-get update && sudo apt-get install unetbootin

See also https://help.ubuntu.com/community/InstallingSoftware

share|improve this answer
    
that worked, I didn't know it was in the reps...anyways that error is weird, any idea on that? –  Matteo Jun 24 '13 at 22:55
    
My guess is as above, what is the output of file ./unetbootin-linux-584 ? –  bodhi.zazen Jun 25 '13 at 0:18
    
you were right! this is the output: ./unetbootin-linux-584: ELF 32-bit LSB executable, Intel 80386, version 1 (GNU/Linux), statically linked, stripped. I was downloading the 32 bit version...thks so much! ` –  Matteo Jun 25 '13 at 0:49
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.