Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I downloaded Android Development Tool for linux (ADT) and placed it in home directory. After unzipping the files, when I double click the "eclipse" executable file; the eclipse works perfectly fine.

But If I unzip the ADT in a different directory, in my case directory E: (is shown when I boot in windows 7) There double clicking the same "eclipse" executable file does not run eclipse. It shows error message:

Could not display /media/Software/00.AndroidLinux/ADT/eclipse/eclipse. There is no application installed for executable files. Do you want to search for an application to open this file?

If I press yes in the Dialog, it finds "Pypar2" which is not my solution.

I found that the "eclipse" file permission is following

-rw------- 1 tanvir tanvir 63050 Feb  4 19:05 eclipse

I tried to change the permission by "chmod +x eclipse" , but no use. This command does not change the file permission at all in this case.

what should I do?

Relevant output of cat /proc/mounts:

/dev/sda6 /media/Software fuseblk rw,nosuid,nodev,relatime,user_id=0,group_id=0,default_permissions,allow_other,blksize=4096 0 0

Please not that I'm new to Ubuntu and still learning day by day.

share|improve this question
    
Welcome to Ask Ubuntu! What kind of filesystem are you using on /media/Software? (Please include the output of cat /proc/mounts in your question.) I guess this is a non-Linux filesystem which cannot hold file permission metadata, e.g. FAT32 and NTFS cannot. –  gertvdijk Jun 24 '13 at 16:07
    
/media/Software is NTFS file system. –  bappi48 Jun 24 '13 at 16:07
    
Is /media/Software loaded automatically at boot, or is it a manually-mounted partition? –  Thomas W. Jun 24 '13 at 16:27
    
[/media/Software] is manually-mounted partition @ThomasW. –  bappi48 Jun 24 '13 at 16:30

1 Answer 1

up vote 2 down vote accepted

Following worked for me:

First, save the old copy of /etc/fstab to say $HOME/fstab.old

Now run

$mount  

to get the device type (eg, /dev/sda3), look for where the drive is mounted,

Example:

/dev/sda3 on /some/path type fuseblk (rw,nosuid,nodev,allow_other,default_permissions,blksize=4096)  

(NOTE: In your case the device type and the directory where it's mounted will be different).

Find the UUID of the disk by running:

$blkid  

On my system this returned:

/dev/sda3: UUID="90FEDFC7FEDFA3AE" TYPE="ntfs"  

Copy/paste the following entry in your /etc/fstab file: (run gksudo gedit /etc/fstab to edit)

UUID=90FEDFC7FEDFA3AE /media/Software ntfs rw,noauto,users,exec,nls=utf8,umask=003,gid=46,uid=1000    0   0  

(NOTE: WRITE THE UUID OF YOUR DISK. Also provide any path that is convinient to you).

Restart your computer.
Now you should be able to execute any file.

share|improve this answer
    
There's no need to reboot on a manually mounted partition to reactivate the settings. Having said this, you also need to use 'noauto' if you don't want fstab to try and automount the partition at boot. I modified your post accordingly –  Thomas W. Jun 24 '13 at 16:34
    
I suppose then you've to remount the drive (Correct me if I'm wrong). –  mohit Jun 24 '13 at 16:36
    
You should unmount the drive first, modify the fstab data, and then remount and it should work with exec permissions. However, you have a lot more options than are needed for basic mounting of an NTFS with exec permissions. I will include my fstab I use for one of my executable NTFS flash drives that ends up mounted at /media/ProgramUSB as an example. That is, when I get home. –  Thomas W. Jun 24 '13 at 16:38
    
Thanks for the correction. –  mohit Jun 24 '13 at 16:38
    
Okay, so, on my system I ended up finding a different NTFS entry, but it works for my needs. This mounts with the ability for the GUI to mount it to the specified path, alows read/write, has executable permissions, and mounting is NOT attempted at boot. The problem with this though is that the NTFS partition type can't be mounted via command line using mount /path in an installation, and needs sudo, something about NTFS user mount support not being built into the tools or something (12.04): UUID=SOME-UUID /media/16GBBitcoin ntfs noauto,user,rw,exec 0 0 –  Thomas W. Jun 24 '13 at 16:42

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.