Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to install Matlab on Ubuntu 12.04, I have a 32bits machine. I downloaded the files and set the file install to exectable, then run :

$ ./install -v

but then I got the error :

Error : Cannot locate Java Runtime Environment (JRE).
The directory /Unix_MAC/sys/java/jre/glnx86/jre does not exist.

So I decided to add the path of matlab's jre to the command ( But before I went to sys/java/jre/glnxa64/jre/glnxa64 and changed the file java to executable), then tried :

$ ./install -v -javadir /home/mbenseddik/Unix_MAC/sys/java/jre/glnxa64/jre/

But then I got the following error :

Preparing installation files ...
cp: impossible d'évaluer «/home/mbenseddik/Unix_MAC/bin/glnx86/*»: No such file or directory
->  DVD                 = /home/mbenseddik/Unix_MAC
->  ARCH                = glnx86
->  DISPLAY             = :0.0
->  TESTONLY            = 0
->  JRE_LOC             = /tmp/mathworks_11294/sys/java/jre/glnx86/jre
->  LD_LIBRARY_PATH     = /tmp/mathworks_11294/bin/glnx86


    Command to run:

/tmp/mathworks_11294/sys/java/jre/glnx86/jre/bin/java -Xmx512m  -splash:"/home/mbenseddik/Unix_MAC/java/splash.png" -Djava.ext.dirs=/tmp/mathworks_11294/sys/java/jre/glnx86/jre/lib/ext:/tmp/mathworks_11294/java/jar:/tmp/mathworks_11294/java/jar/ja_JP/:/tmp/mathworks_11294/java/jar/zh_CN/:/tmp/mathworks_11294/java/jarext:/tmp/mathworks_11294/java/jarext/axis2/:/tmp/mathworks_11294/java/jarext/guice/:/tmp/mathworks_11294/java/jarext/webservices/ com/mathworks/professionalinstaller/Launcher -root "/home/mbenseddik/Unix_MAC" -tmpdir "/tmp/mathworks_11294" 

Installing ...
/tmp/mathworks_11294/sys/java/jre/glnx86/jre/bin/java: 1: /tmp/mathworks_11294/sys/java/jre/glnx86/jre/bin/java: Syntax error: "(" unexpected
Finished

It seems like it is looking for glnx86 whereas the only directory inside the sys/java/jre directory is glnx64...

Any idea on the matter ?

share|improve this question
    
From this answer, try ./install -v -javadir <location of jre in your machine>, so you'd try ./install -v -javadir /home/mbenseddik/Unix_MAC/sys/java/jre/glnxa64/jre/. –  Alaa Ali Jun 24 '13 at 8:35
    
@Alaa Thanks for your answer, how can I find the location of jre in my machine ? –  akari Jun 24 '13 at 10:08
    
./install -v -javadir /home/mbenseddik/Unix_MAC/sys/java/jre/glnxa64/jre/, isn't that the directory where you found glnx64? I'm just saying you can try the same command you tried in your question, but add the -javadir option. –  Alaa Ali Jun 24 '13 at 10:36
    
Yeah, I tried that but it didn't work neither, I'm getting the same error... I thought you were speaking about the jre in my machine and not the one in Matlab's installing folders... I thought it may work if I try using it, but I don't know what is the path to it ? –  akari Jun 24 '13 at 11:13

2 Answers 2

up vote 1 down vote accepted

Unfortunately, MATLAB 2013a is not compatible with Linux 32 bit. The last release of MATLAB to be compatible with this platform was R2012a.

share|improve this answer
    
how did you know that ? –  Amir Oct 25 '13 at 14:27

http://www.mathworks.com/matlabcentral/answers/94005

Here is the mathworks page the explains all the requirements. I just ran into the same problem and figured I'd add it for other people browsing.

share|improve this answer
    
Welcome to Ask Ubuntu! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  minerz029 Jan 17 at 1:01

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.