Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to install openbts but it requires a bunch of dependencies, some of which fail:

The following packages have unmet dependencies: libboost-all-dev : Depends: libboost-python-dev but it is not going to be installed libsqlite3-dev : Depends: libsqlite3-0 (= 3.7.9-2ubuntu1) but 3.7.9-2ubuntu1.1 is to be installed sqlite3 : Depends: libsqlite3-0 (= 3.7.9-2ubuntu1) but 3.7.9-2ubuntu1.1 is to be installed

I figure that I can structure the command in such a way as to ignore the different versions on the sqlite stuff and install it anyways (is this okay?) but what I don't understand is what's going on with libboost.

    # apt-get install libboost-all-dev

Reading package lists... Done Building dependency tree
Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation:

The following packages have unmet dependencies: libboost-all-dev : Depends: libboost-python-dev but it is not going to be installed E: Unable to correct problems, you have held broken packages.

    # apt-get install libboost-python-dev

Reading package lists... Done Building dependency tree
Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation:

The following packages have unmet dependencies: libboost-python-dev : Depends: libboost-python1.46-dev but it is not going to be installed

I thought I might have a different version installed:

    # apt-get remove libboost-all-dev

Reading package lists... Done Building dependency tree
Reading state information... Done Package libboost-all-dev is not installed, so not removed 0 upgraded, 0 newly installed, 0 to remove and 163 not upgraded.

same for this:

    # apt-get remove libboost-python-dev

Reading package lists... Done Building dependency tree
Reading state information... Done Package libboost-python-dev is not installed, so not removed 0 upgraded, 0 newly installed, 0 to remove and 163 not upgraded.

    # apt-get install libboost-python1.46-dev

Reading package lists... Done Building dependency tree
Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation:

The following packages have unmet dependencies: libboost-python1.46-dev : Depends: python-dev but it is not going to be installed

Could somebody please explain what the heck is going on? Thanks.

share|improve this question
    
Running 12.04 LTS –  user169615 Jun 23 '13 at 16:26

2 Answers 2

If you type the following in to a Terminal window it might help

sudo apt-get -f install libboost-python-dev

 sudo apt-get -f install openbts

The -f option forces `apt-get to down load the required dependencies.

share|improve this answer

try the build-dep option that's the best option for getting out of the dependencies nightmare. sudo apt-get build-dep <package-name> (openbts in your case)

This would automatically build all the required dependencies.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.