Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a 3-4 years old laptop (Compaq V3000), which had Win Vista with Ubuntu 10.10 in dual boot configuration. The graphics card inside is an old Nvidia GeForce Go 7200.

One fine day, my graphics card died (of old age, presumably) - resulting in myself being initially unable to boot to WinVista and Ubuntu 10.10. I solved the problem with WinVista (disabled Nvidia card after booting to Safe mode), but I don't know how to do the same with Ubuntu. I can only disable the 3rd-party driver after I boot to desktop, but since its crashing before that, I'm unable to do so.

Can anyone help me disable the graphics card in Ubuntu?

share|improve this question
    
Why not booting ubuntu in safe mode too? –  Pitto Mar 20 '11 at 13:57
    
Ummm....how to do that ? –  TCSGrad Mar 20 '11 at 17:01
    
You should boot into recovery console (choosing this in grub) –  Pitto Mar 21 '11 at 13:28

2 Answers 2

Looks like you've issues with your initial ramdisk (initrd) which expects your nVidia card. You'll need to update this initrd.

Boot with a LiveCD and follow the next steps:

  1. Mount your Ubuntu root partition, change XY accordingly:

    sudo mount /dev/sdXY /mnt
    
  2. Mount some partitions:

    sudo mount --bind /dev /mnt/dev
    sudo mount --bind /proc /mnt/proc
    sudo mount --bind /sys /mnt/sys
    
  3. Change your root directory to the mounted Ubuntu partition:

    sudo chroot /mnt
    
  4. You'll end up in a root shell, now update the initial ramdisk (this may take a few seconds):

    update-initramfs -u
    
  5. Now you're finished, exit from the chroot and unmount some filesystems:

    exit
    sudo umount /mnt/{sys,proc,dev} /mnt
    
  6. Reboot.
share|improve this answer
    
Does your response mean that the "initial ramdisk" would by itself figure out that the nvidia card has gone bad, and would no longer try to use it ? I'm asking as I didn't see anything that looked like disabling the card specifically....I just wanted to understand how this was going to work (not doubting the solution!!). –  TCSGrad Mar 20 '11 at 17:04
    
Your initial ramdisk contains the required drivers for the system. By updating it, it will look for drivers again: no video card? We won't put it in it then. For more information about initial ramdisks, see this Wikipedia article. –  Lekensteyn Mar 20 '11 at 20:12

I've had this situation happen to me recently except on my case the proprietary drivers wouldn't play nice with my nvidia gt 220 card and so I need to disable it, booting normally crashes the boot process.

So tried to boot using the recovery console, got to the terminal as root and then just did

apt-get remove nvidia-current

Rebooted and then logged in and enabled the nouveau driver. So far everything is working now with compiz.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.