Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This happened when I tried to upgrade from 12.04 to 12.10. I don't know whether the upgrade process had completed downloading and installing packages or whether it was still in progress, but I got a message The application Compiz has closed unexpectedly.

At that point, my mouse stopped working so I switched to tty1 by Ctrl+Alt+F1 and rebooted from there.

I then found that I could not boot into Ubuntu any more. My screen stayed first purple then black. I went back to tty1 and it said I was running 12.10.

I tried some suggestions in this thread on Ubuntuforums: Wubi blank purple screen than blank black screen and this one: How to set NOMODESET and other kernel boot options in grub2 but nothing seemed to work.

I can boot Windows as normal. I am using Wubi on Windows7. My laptop is a Lenovo T410i with NVIDA NVS 3100m

share|improve this question
    
Try booting in recovery mode and repairing packages: hold down Shift key to get the Grub menu, select Advanced options, then the 2nd Recovery mode entry. Also removing and reinstalling the nvidia driver. –  bcbc Jun 23 '13 at 17:27
    
@bcbc Hi, I got a recovery menu which has following options: resume;clean;dpkg;failsafeX;fsck;grub;network;root;system-summary; What do I do from there? If I resume I would have the same problem as I described before. –  ywx Jun 24 '13 at 8:25
    
Select dpkg - repair broken packages. –  bcbc Jun 24 '13 at 15:03
    
That works! Now I'm able to get back to Ubuntu desktop, however there is still error: "Error: BrokenCount>0. This usually means that your installed packages have unmet dependencies." How to fix this? –  ywx Jun 24 '13 at 19:39
    
Try sudo apt-get install -f (fixes broken dependencies) –  bcbc Jun 24 '13 at 20:23
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.