Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I was watching a movie and suddenly I was logged out. When I logged back in, Team Viewer was started immediately, although it's not on startup programs.

Quickly I opened the terminal and gave the command sudo last, but it was not showing anything suspicious. Last but not least, no updates were made​​.

Any idea?

share|improve this question
2  
This site is not fit for urgent matters. It is also very specific to your situation probably. For a forensic analysis on your system consult an expert with access to the machine. A Q&A site is not the right place, really. I'm editing your question as per How do we deal with “urgent!” questions? –  gertvdijk Jun 23 '13 at 12:07
4  
If you sincerely feel that your machine has been compromised, take it off-line and rebuild it from scratch. There is not much more we can help you with here as we don't perform forensics. –  Kevin Bowen Jun 23 '13 at 12:11
2  
Also, what do you expect for an answer? Do you want to know whether this is suspicious or not? What happened exactly? How to trace the attacker? etc. A statement about what you saw and then "Any idea?" does not really show your actual question. –  gertvdijk Jun 23 '13 at 12:11
    
Tried dmesg | tail or just dmesg? –  Host-website-on-iPage Jun 23 '13 at 12:23
add comment

1 Answer 1

Your system was likely not attacked. Teamviewer starts with the system by default (annoying I know, but true anyway) in the latest version I've tried.

The solution is to check both startup programs, and the following locations:

/home/rolandixor/.config/autostart
/usr/share/autostart

for an entry for Teamviewer, and if it exists, to remove it.

You were likely logged out due to a Xserver crash (this occasionally happens when watching videos or playing games, especially on proprietary drivers in my experience). Make sure that you apply any updates you may have missed.

share|improve this answer
    
well, thanks for your answer, but stil....i just checked in /home/my-username/.config/autostart and there are only 2 programs (dropbox.desktop and remina-applet.desktop) –  iuliancalin Jun 23 '13 at 21:08
    
in /usr/share/...autostart folder does not exist –  iuliancalin Jun 23 '13 at 21:16
    
I have the system up to date –  iuliancalin Jun 23 '13 at 21:26
    
Run locate autostart and look for a Teamviewer.desktop file in any of the folders you find. –  RolandiXor Jun 24 '13 at 5:00
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.