Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have Ubuntu 12.04 LTS installed on my main laptop and my old machine runs Win XP. The Win XP machine configures a Buffalo LS-XL65F Network Attached Storage device.

I'm having a problem with Deja-Dup and backing up my Ubuntu Home folder to the NAS Device. When I try to configure Deja-Dup to connect to the NAS device (which is configured on the Windows XP machine), I always get the error message, "Failed to Mount Windows Share".

I can mount the NAS Windows Share using Nautilus file browser and copy the files to the NAS manually, but I would like configure Deja-Dup to do it regularly, on a weekly basis.

I'm not sure if was necessary or not, but I downloaded and installed Samba, and tried to configure that.

I'm guessing there must be something wrong with my syntax in Deja-Dup. I'm also no expert in Linux. The syntax I'm using looks like this:

enter image description here

Is there something obvious that I'm doing wrong?

Thanks in advance.

share|improve this question
    
I thought I'd better add some more info. I tried to download and configure Samba, not sure if that was necessary or not, but I'm including a screen-shot of my Samba Server settings. I also downloaded the NTFS configuration tool, as I believe the NAS is formatted with NTFS. Configuration tool image included. Finally I read that is necessary to edit the fstab file, so tried to edit that but not sure of correct syntax for mounting a Windows share at boot up. imgur.com/a/5QE5a –  Cacique83 Jun 30 '13 at 7:24

1 Answer 1

I am new to Ubuntu Linux myself, but I would like to post what worked for me. I use a Linkstation Live by Buffalo as my NAS. The name of my station is the model, which is LS-XLC5D. When I created my folder on the NAS I wanted to back up to, I set it up with support for Windows, Apple, and FTP.

On Linux, in Deja-Dup under Storage I set Windows Share to be the backup location. I put the IP address of the NAS in the Server field. I put the name of the folder in the Folder field. I left username blank, and put WORKGROUP in the Domain field (you would probably have MSHOME from the look of it).

From this, when I tried to do the backup, it asked me for my username and password, which is the same as if you were logging into the web configuration panel (default is admin/password I believe). Then it asked if I wanted to encrypt the backup and it ran successfully.

The main thing for me was not to use the name of the Linkstation as the server; use the IP address. I got that tip from this website.

I also suppose it will be of great help to set the IP of your NAS to be static. That way if you unplug the NAS and restart the router it won't change the IP address, otherwise you would have to go into backup settings and manually enter the new IP. But that worked for me. Also, I did not need to install Samba at all to get this to work.

I hope this helps!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.