Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have had my display working correctly on a new machine (Ubuntu 13.04 64-bit, ATI Radeon HD6670) for the last 3 weeks using the proprietary driver downloaded from the ATI website. Yesterday, I rebooted the machine and now Compiz is broken. I have no Unity menu, no sidebars, no window decoration. I have tried following the instructions:

Compiz has broken after installing 12.10 with ATI Catalyst 12.10 drivers

to completely remove the driver, rebuild the .deb packages and reinstall. However I still have no compiz etc. fglrxinfo gives:

    sudo fglrxinfo
display: :0.0  screen: 0
OpenGL vendor string: Advanced Micro Devices, Inc.
OpenGL renderer string: AMD Radeon HD 6670
OpenGL version string: 4.2.12217 Compatibility Profile Context 12.104

actually ps aux|grep compiz indicates that compiz is actually running, but I have no effects (e.g. prior to the reboot I had "wobbly windows" effect), no window decoration & no Unity launcher.

Thanks.

When I start gnome-panel from a terminal, it starts but gives:

(gnome-panel:5308): Gtk-CRITICAL **: gtk_accelerator_parse_with_keycode: assertion `accelerator != NULL' failed

** (gnome-panel:5308): WARNING **: Unable to parse mouse modifier '(null)'

Windows can't be moved or resized

share|improve this question
    
I think I have pinned this down to something in my profile. If I create a new user & log in as them, the display works fine. Any suggestions appreciated on which files I need to copy across from the other user to correct my display problem. –  Alan Patterson Jun 23 '13 at 12:04
    
Could be something wrong with xorg.conf. After removing proprietary driver did you do sudo rm /etc/X11/xorg.conf then a reboot? –  Chris Carter Jun 23 '13 at 12:25
    
Hi Chris, yes I did remove xorg.conf, however, it turns out to be a compiz config issue. I resolved this by starting compiz settings manager, going to "preferences" and "Reset to Defaults". All ok now. Cheers, Alan –  Alan Patterson Jun 23 '13 at 12:29
    
Glad you got it sorted, you can provide and accept your own answer. It may help others in the future. –  Chris Carter Jun 23 '13 at 12:32
    
Yep will do, it won't let me for another 4 hours though for some reason –  Alan Patterson Jun 23 '13 at 13:24
add comment

1 Answer 1

I resolved this by starting compiz settings manager (sudo apt-get install compizconfig-settings-manager), going to "preferences" and "Reset to Defaults".

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.