Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've installed Ubuntu and Lubuntu a few times now and some of those times I've had the following problem, which I currently have. When I click a torrent magnet link in Chrome (usually from Pirate bay), instead of opening transmission, the only thing that happens is a new Chrome window opens.

Upon other installations, I've not had this problem; transmission opened just as I'd like.

I've tried using Chrome's extension .torrent to Transmission, but I get the error

unable to contact http ://localhost:9091/transmission/rpc

no response

share|improve this question
    
This should help [How to tell chrome what to do with a magnet link][1] [1]: askubuntu.com/questions/108925/… –  BiggJJ Jun 22 '13 at 21:07
    
Note: I'm using Lubuntu 13.04. –  Quinn Culver Jul 13 '13 at 15:52
    
Note: Firefox correctly handles magnet links. –  Quinn Culver Jul 13 '13 at 16:14
    
@BiggJJ I tried following Chan-Ho Suh's solution there, but to no avail. –  Quinn Culver Jul 14 '13 at 2:44
    
What version of Google chrome are you running? I use Google Chrome 28.0.1500.71 and it correctly handles magnet links withot to do nothing. –  Radu Rădeanu Jul 14 '13 at 8:59

7 Answers 7

up vote 2 down vote accepted

If you want to use torrent to transmission, you have to allow remote access in transmission under preferences/remote.

If you want to open magnet links in transmission by clicking on them, you need to patch the /usr/bin/xdg-open script, here's mine for reference. The added lines are 311 and 490-493.

share|improve this answer
    
Thanks, this is the only solution that worked for me. –  Bogdan Vancea Jun 4 at 9:10

You can change the default handler for magnet links by editing the file .local/share/applications/mimeapps.list. Add the association to the two sections in the file like this (leaving other entries in those sections intact):

[Default Applications]
x-scheme-handler/magnet=transmission-gtk.desktop

[Added Associations]
x-scheme-handler/magnet=transmission-gtk.desktop

Log out and log back in for the change to take effect.

share|improve this answer
    
I tried this but I hasn't seemed to work. Still chrome just opens a new browser (or a new tab separate from the others; however you wanna put it). –  Quinn Culver Jul 21 '13 at 14:50
    
There's no transmission.desktop in transmission's source file. Check if you meant transmission-gtk.desktop. –  Braiam Jul 21 '13 at 15:26
    
@Braiam Yes, I tried with and without the -gtk. –  Quinn Culver Jul 21 '13 at 16:12

If you have installed transmission-gtk then the solution is easy.

gconftool-2 -s /desktop/gnome/url-handlers/magnet/command '/usr/bin/transmission-gtk %s' --type String
gconftool-2 -s /desktop/gnome/url-handlers/magnet/enabled --type Boolean true

The first one adds transmission-gtk as handler for magnet:// links the second enable it.

Since chrome/ium uses xdg-open this is the best method for setting the handlers. You can replace /usr/bin/transmission-gtk for any client you like. This works for almost all flavors of Ubuntu.

You can test this issuing in the terminal xdg-open "magnet:?xt=urn:btih:f41989f9797a88505f9e258d5e5d1354c3731a99" (downloads Ubuntu 13.04 64-bit)


Other solution is using xdg-mime:

xdg-mime default transmission-gtk.desktop application/x-bittorrent
xdg-mime default transmission-gtk.desktop x-scheme-handler/magnet

In case you don't have the mime-types installed use xdg-mime install x-scheme-handler/magnet.

share|improve this answer
    
This doesn't seem to have worked. Still, even when I try your test from the terminal (to download Ubuntu), it opens a new Chrome window. –  Quinn Culver Jul 21 '13 at 16:06
    
@QuinnCulver What's the output of gconftool-2 -g /desktop/gnome/url-handlers/magnet/command? –  Braiam Jul 21 '13 at 16:50
    
The output is: /usr/bin/transmission-gtk %s –  Quinn Culver Jul 21 '13 at 17:00
    
@QuinnCulver and gconftool-2 -g /desktop/gnome/url-handlers/magnet/enabled? Try logging out to force the values to be updated. –  Braiam Jul 21 '13 at 17:10
    
The output is: true. I'd rebooted last time I tried your suggested commands. I'll try again; this time I'll only log out. –  Quinn Culver Jul 21 '13 at 17:23

If you want to Open Piratebay magnet link with Transmission Client then on Magnet Link 1 Right Click 2 Copy Link Location Open Transmission File> Open URL

It's Done

share|improve this answer

unable to contact http ://localhost:9091/transmission/rpc

no response

To fix this

  1. Install transmission-remote
    sudo apt-get install transmission-remote

  2. Start transmission (transmission-gtk) before adding .torrent files

  3. Enable web client, set port to 9091 (From edit -> preference -> web ) if necessary
share|improve this answer
    
omgchrome.com/install-google-chrome-in-ubuntu-13-10 This claims there is a dependency issues. –  j0h Jul 14 '13 at 18:58
    
askubuntu.com/questions/108925/… –  j0h Jul 14 '13 at 19:25
    
I tried this. It didn't seem to work. –  Quinn Culver Jul 21 '13 at 16:11

I suspect that you have installed transmission remote GUI instead of Transmission BitTorrent client. Please check in the software center and if I am correct, uninstall the former and install the latter.

share|improve this answer
    
I have both installed. –  Quinn Culver Jul 21 '13 at 14:53

if ur using bittorrent go to preferences-general-click on the tab that says associate with torrents..now it will work when you try magnet link..

share|improve this answer
    
You actually have to add the bittorrent entry to the xdg-open list to make this work with chrome as far as I know. Also bittorrent is a name for the system so almost all bittorrent clients have the word bittorrent in it's name. –  Arno van der Weijden Dec 12 '13 at 7:07

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.