Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

[Edit 3: Before you read all of this, I don't think this is a software issue anymore, so I'm not sure if there's a real solution that can be offered. I saw this video and read some of the comments. It appears this is probably my issue.

Here is my reasoning. (1) My wife has an identical comp with the same OS and the same updates. No issues. (2) I have tried multiple combinations of kernels and iwlwifi firmware. Each have the same problem. (3) When I remove all of the iwlwifi firmware and use a usb wireless adapter, everything works great. (4) When I jostle it (like when I open the lid on resume) it is more apt to crash.

Put together, I'm going the hardware route. Thanks for people who read and upvoted. ]

My laptop (Asus U56E) is having problems with its wireless. It either (1) randomly disconnects or (2) crashes the entire system. The most consistent way I can reproduce it, is putting the laptop to sleep and changing the power state (i.e., unplugging if it was plugged in or vice versa).

Here is my wireless card:

$ lspci | grep -i wireless
02:00.0 Network controller: Intel Corporation Centrino Wireless-N + WiMAX 6150 (rev 67)

I have had similar problems on elementary Luna Beta 2 and Lubuntu 13.04 (So I don't think it's kernel related because they use different kernels). I've done fresh installs of each. Most recently in Lubuntu, after toggling the power state during a suspend, it would not resume. On the screen it read:

[  102.433193] i2400m_usb 1-1.1:1.0: device reset on resume: reinitializing driver
[  150.661359] iwlwifi 0000:02:00.0: Failed to load firmware chunck!
[  150.661359] iwlwifi 0000:02:00.0: Could not load the [0] uCode section
[  150.661433] iwlwifi 0000:02:00.0: Failed to start RT ucode: -110
[  151.000810] iwlwifi 0000:02:00.0: Unable to initialize device.

This has been an ongoing thing for the past 2 weeks. Can someone point me in a direction here? Is this most likely (1) a driver or other software issue or (2) a hardware issue?

If it's a driver/software issue, I'll gladly provide more information. I'm just out of my element here. I'm desperate!

[EDIT: Wireless seems to have a tough time resuming after the computer has been suspended for a lonerg period of time (>30 mins).]

[EDIT2: When I run into the wireless issue, it appears the my wlan1 dissapears. Is there a way to get it back? For example, when I reboot my computer and run iwconfig I get the following:

lo        no wireless extensions.

wlan1     IEEE 802.11bg  ESSID:"HampNet"  
          Mode:Managed  Frequency:2.437 GHz  Access Point: 14:35:8B:00:49:38   
          Bit Rate=54 Mb/s   Tx-Power=15 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=66/70  Signal level=-44 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:3  Invalid misc:63   Missed beacon:0

eth0      no wireless extensions.

But when my computer fails after a resume or the wireless simply crashes, my iwconfig looks like this.

lo        no wireless extensions.

wmx0      no wireless extensions.

eth0      no wireless extensions.

]

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.