Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I have this font that I want to use for Amharic/Ethiopic, while leaving the default for other characters, notably Latin. The problem is my Ubuntu OS seem to have a random way of choosing from among the numerous Ethiopic fonts I have installed. I don't wan't to choose my preferred Ethiopic font as the system default either as I don't like the Latin characters it has. Any advice on how I can manipulate or configure this?

share|improve this question

migrated from Jun 22 '13 at 17:29

This question came from our site for professional and enthusiast programmers.

1 Answer 1

Check this link on how to enable Amharic Input on Ubuntu 12.04

EDIT: the steps outlined are merely copied from the link above.

Installation Steps

wget -qO - | sudo apt-key add - 
sudo add-apt-repository "deb $(lsb_release -sc) main"
sudo apt-get update
sudo apt-get install ibus-kmfl  kmfl-keyboard-sil-ethiopic fonts-sil-abyssinicasil

After installation follow the following configuration steps

  1. Choose IBus as the input method

    • Open 'Language Support '
    • Choose 'ibus' from drop down following 'Keyboard input method system: ' option
    • Close
  2. Setting up Amharic

    • Open 'Keyboard Input Methods '
    • Go to 'Input Method' tab
    • Enable 'Customize active input method'
    • Select your 'Other' -> 'SIL Ethopic #.#' (#.# may change from time to time as upgrades are made) from the drop down menu and click 'Add button'
    • Move it up to the top so that whenever you run ibus you will be directly able to type in your language.
    • Close
    • Logout and Login
  3. Running IBus on System Startup

    • Open 'Startup Applications'
    • Click on the "Add" button
    • Write command as: "ibus-daemon" and give whatever name you want
    • Click on the "Add" button
    • Enable it
    • Close

You should get a keyboard icon on the top panel near the digital clock. You can use to choose 'Other - SIL Ethiopic #.#' or press 'Ctrl + Space' keys to start typing in አማርኛ።

The guide was made by following the instruction in the following links;

share|improve this answer
Welcome to Ask Ubuntu! While this blog post might contain a solution to the problem, it would be preferable to include the necessary steps in your answer. – Donarsson Mar 14 '14 at 16:23
I appreciate you taking time to answer, but what I was looking for was a means to control what font my system chooses for Amharic. Currently I have no control on how it chooses the fonts. I am already able to type in Amharic; I even written a blog with instructions on how to enable it. BTW, this also concerns other languages with non-Latin script. – Eyob Mar 3 at 10:28

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.