Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I got a new machine with i7 4770k and gefore gtx660. I installed windows and then installed Ubuntu 13.04. In the installation everything went well, after the installation I again boot from the USB and choose try ubuntu, and installed boot-repair because windows automatically boot with no option for ubuntu.

After I repaired the boot, I restarted and got into grub, when I chose Ubuntu I got message saying I'm running on low graphics mode and when I pressed ok the screen turned off. I couldn't do anything so I restarted and after reading this post: My computer boots to a black screen, what options do I have to fix it?

I got into recovery, selected dpkg and repaired packages. Then I rebooted, and tried to press 'e' and change quiet splash to no splash and nomodeset but unfortunately both of them didn't work, and not the screen didn't get turned off, but I just saw a blank screen.

So I rebooted again, entered the recovery, and this time I went to the root shell, and tried to install nvidia drivers from this guide here: http://www.howopensource.com/2012/10/install-nvidia-geforce-driver-in-ubuntu-12-10-12-04-using-ppa/

I rebooted and got the same black screen again (the screen didn't go off, just saw a blank screen).

In the grub I see that the kernel is 3.8.0-25.

I also checked that the usb files are not corrupted using the check CD from the ubuntu installation screen.

I'm really frustrated, I don't know what else can I do.

(If someone also knows how can I connect to wifi using the root shell it will be very appreciated, because when I choose the 'enable networking' it again booting me to a black screen.

Thanks


Edit


After digging more, I again boot with nomodeset and saw where is it failing, this is the lines I saw:

* Starting Reload cups, upon starting avahi-daemon to make sure remote queues are populated [OK]

* Starting Reload cups, upon starting avahi-daemon to make sure remote queues are populated [fail]

I searched for it in google and this is the closest result I got: http://ubuntuforums.org/showthread.php?t=2144261

i didn't find any way to solve it in the internet, from what I understand this is a problem with 13.04. If someone knows how to fix it I will be very grateful.

Thanks


Edit 2 - 23.6.13


As Mitch suggested, I disabled the avahi-daemon, and when I boot in nomodeset I get the following error: enter image description here

What else can be the problem?

share|improve this question
    
@Mitch, as djeikyb said, I already tried everything mentioned in the post you said it was duplicate (I even linked this post in my question). Anyway, after trying a lot of things, I tried nomodeset again and this time I saw where it was failing, I will edit my question. –  Elad92 Jun 22 '13 at 18:27
    
Try This. Let me know if it works, and I will nominate this question to be re-opened. –  Mitch Jun 22 '13 at 19:06
    
@Mitch, tried this, I tried to boot without nomodeset, I heard the lock screen sound of Ubuntu but only black screen. I tried to boot again this time with nomodeset, and got an error message: 'DRM: Fill_in_dev failed'. I'm adding a picture in my question. Can you please open the question again? Thanks. –  Elad92 Jun 22 '13 at 21:51
    
I tried few more this: * Installed Ubuntu 13.04 on my HDD (now it's on SSD), same thing. * Reinstalled nvidia drivers * Tried to fix broken packages * Tried to use gdm instead of lightdm but nothing. Any more suggestions? –  Elad92 Jun 23 '13 at 17:45
add comment

closed as off-topic by Richard, Eric Carvalho, BuZZ-dEE, Jorge Castro, Braiam Apr 14 at 0:11

This question appears to be off-topic. The users who voted to close gave this specific reason:

If this question can be reworded to fit the rules in the help center, please edit the question.

1 Answer

up vote 1 down vote accepted

Ok, after a lot of researching I found the problem. For those who doesn't know, DRM is something connected to graphics in linux. I found this bug here that was closed, but the bug reporter mention something about i915. After I looked for my graphic devices on my computer I saw that it recognize the Intel integrated graphics (4600 hd) and its driver name is i915. I opened the BIOS and found an option to disable the Intel graphic card, so I did it and viola, my desktop is up again :)

I don't know what it is exactly, I'm just happy it was solved. Maybe because this CPU is pretty new the linux kernel doesn't have the drivers for it.

Anyway, I hope it will help someone, and thanks for everyone who tried to help!

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.