Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I downloaded Ubuntu 13.04 (amd 64 bit) iso to install it as a dual boot on my Sony Vaio SVT14116PN.

It has a pre-installed Windows 8 Pro with Secureboot enabled.

Here are the steps I followed:

  1. Disabled Secureboot on the BIOS
  2. Disabled UEFI in the BIOS
  3. Disabled Fast shutdown in Windows 8
  4. Created Bootable USB drive using Universal USB Installer. (
  5. I have created a 50 GB partition in Windows 8

It starts to boot from USB and displays the choice screen asking whether to try or install Ubuntu.

I clicked "Install Ubuntu".

Since I use a 3G data card to connect to the internet, I had to continue installation without internet connection.

After which I get to the following screen:

Install Screen 4:

No matter which button I click ( + , - , change , continue ) I get this error:


It says Ubuntu encountered an internal error.

I tried creating the USB again but it didnt work ... any help ??

This is the error report: Error details 1 Error details 2

share|improve this question

1.Start your windows and open disk management.

2.Delete the partition newly created(50GB) and make it unallocated(Free space).

3.Now try to install ubuntu alongside Windows8 using the live USB you had created earlier.

share|improve this answer
ok .. let me try that and let you know – Aseem Chiplonkar Jun 22 '13 at 7:08
Sorry @Ashok .. but I get the same error ... – Aseem Chiplonkar Jun 22 '13 at 7:23

First, you should not disable EFI/UEFI in your firmware if you intend to dual-boot with the existing Windows 8 installation. At best, the firmware will ignore this option and you'll end up with an EFI-based installation anyhow. At worst, disabling EFI/UEFI support will result in a BIOS-mode Ubuntu installation aside an EFI-based Windows installation, which will complicate your boot loader/boot manager setup and your OS selection when you boot. This is almost certainly not the source of the problem about which you're posting, but it deserves prominent mention lest you overcome that problem and run into another one right away....

As to your problem, it appears that the installer is recognizing your hard disk as being completely unpartitioned, despite the fact that it's got existing partitions. This symptom is usually caused by one of three problems:

  • Leftover RAID data on a disk that's not actually using RAID. If you're positive that your disk isn't using RAID, you may be able to overcome this problem by typing sudo dmraid -E -r /dev/sda. Don't type this command unless you're positive that you're not using RAID, though; if you are using RAID, this command will damage your RAID data structures.
  • A damaged partition table. This can be better diagnosed using gdisk, which is installed in the gdisk package, IIRC. See the gdisk documentation on disk repairs for details; but in brief, launching gdisk on the disk and then typing v should produce a list of problems with the disk. gdisk can fix some such problems automatically, but others will require more work to identify and fix. Be cautious; if you don't know what you're doing, you can end up doing more damage with gdisk. If you try gdisk and suspect your partition table is damaged but you don't know how to proceed, please edit your original post and include gdisk's output. (Precede each line cut-and-pasted from a Terminal window with four spaces to format it in a monospace font for legibility.)
  • An unsupported disk controller. If your hard disk isn't recognized by Linux, then Linux can't do anything with it. IIRC, though, you wouldn't see "/dev/sda" in the radio button near the bottom of the first screen shot if this were the case, so I doubt if this is what the problem is. If it is, though, you might be able to get it to work by moving the hard disk's cable from one motherboard connector to another -- many motherboards have multiple disk controllers, and sometimes one of these works with Linux whereas another one doesn't. If this is the problem, then an attempt to use gdisk will produce an error message of The specified file does not exist!
share|improve this answer
I tried by not disabling SecureBoot and UEFI. It took me to the GRUB installation options screen. I get options like Try, Install,Check disk etc. I clicked Check disk. I could not find a way to copy that log. I then clicked Install now, but I get to the same screens with same errors. All the hard disk related options you have given me seem pretty invasive to me. Its not like my life depends on having a dual boot Ubuntu. So I would prefer to wait for a simpler option to get Ubuntu on my machine. Thanks for your answer though. – Aseem Chiplonkar Jun 26 '13 at 2:25
If your problem is, as I'm about 95% sure, a bad partition table or leftover RAID data, then you won't find a "less invasive" solution. In fact, if the problem is a bad partition table, you risk future damage by not taking care of the problem, whether or not you install Ubuntu. Thus, at the very least, I recommend you run gdisk and use its v option. So long as you don't use the w (write changes) option, there's no risk to your disk by doing this, and it will provide you with valuable information about problems or the lack thereof. – Rod Smith Jun 28 '13 at 1:42
thanks for the comment. I did check the disk using Windows built in checkdisk & Hitachi's disk check utility, both reported no errors. So I guess my problem lies in the 5% unsure region ! :) – Aseem Chiplonkar Jun 28 '13 at 4:18
The Windows CHKDISK utility checks filesystems, not partition tables. I don't know what Hitachi's utility does. As the problem I suspect is in your partition table, using a tool that checks for GPT data structure problems is the only way to do, and gdisk can do this. My percentages haven't changed; I'm still 95% convinced that you've got either a partition table problem or RAID data that's causing problems. – Rod Smith Jun 28 '13 at 16:50
Do you know a tool which is similar to gdisk on Windows? Maybe I will try that and check if there is a problem with the partition table. – Aseem Chiplonkar Jul 1 '13 at 3:21

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.