Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I managed to get my wireless working beautifully (ath5k driver working great), and it works over a disable/enable wireless cycle, even a suspend/wakeup cycle (read some people have issues with that). Unfortunately, I discovered that if I press Fn+F2 on my keyboard (Asus EeePC 900HA, so that's the wireless toggle key), wireless then stops working until I restart the computer.

How can I fix this? I'm running UNR 10.10 (with Unity turned off tyvm!). I heard something about Jupiter controlling these keys, but what about asus-laptop? How can I fix this behaviour?

TIA. (Note, I'm a power user, but still fairly new to Linux. I'm picking up speed though).

share|improve this question
    
Did you try Ndiswrapper for the wi-fi? Does it give you the same issue? –  Andrea Lazzarotto May 1 '11 at 8:59
    
Yup. No dice, same problem. –  dawmail333 May 6 '11 at 8:41
add comment

2 Answers 2

up vote 1 down vote accepted

I too have Maverick on a eee900A and I was having the same problem with the wireless. I found this fix, it worked beatifully for me. Hope it helps

Ciao

share|improve this answer
add comment

I have an Asus EeePC myself too, the 1005PE, but im using Lucid 10.04 instead. Ive bought it soon after Lucid was released, and decided to stick with an LTS release. After all, netbooks have limited hardware, and i depend on it on a daily basis, for work and college, so bleeding edge is not needed, stability and long term support comes first.

At least in my particular combination, the Fn+F2 key works perfectly. I can (and i do) switch wireless on and off several times a day. Sometimes I have problems turning bluetooth on and off, requiring restart, but since Eee900 has no bluetooth, it shouldnt worry you.

Also, I didnt have to install any driver. The ones out-of-the-box recognized my harware, from touchpad to wifi and even bluetooth.

So, my suggestions are:

  • Why not try Lucid 10.04? Its LTS, so it will be supported for 3 years instead of 18 months.

  • If you dont use Maverick's Unity, youre already missing the biggest change in that release. So Lucid will look very similat to what youre used to.

  • Power consumption in Lucid is smaller than Maverick. For a Netbook, battery life is crucial.

  • Ive downloaded and installed Jupiter. Not for the Fn keys, but for power management. I strongly recommend it. It really improved my battery life from 8 to 12 hours. HUGE improvement. Check out my answer on a similar question for some info about Jupiter. And yes, it also improved Fn control by enabling OSD Notifications for every Fn key, and it does have independent bluetooth and wireless enable, something my Fn keys do not.

So, why not try it? Lucid 10.04 + Jupiter may be your solution for the Fn+F2. Even if they dont, you wont lose much compared to your current setup (Maverick minus Unity is almost the same as Lucid), and you will get some side-benefits as well, battery life and LTS support to name a few.

You dont need to touch your HDD to try it... use a Live Session to see if Fn+F2 keys work. You can even install Jupiter in a Live Session. Or repartition your HDD to have them both installed side-by side until you feel safe about it.

share|improve this answer
    
I will try this, but the information is useful, so I'll mark it as the answer. –  dawmail333 Jun 7 '11 at 7:36
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.