Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have been on 9.10 for over a year on the grounds that if it ain't broke, don't fix it. However, I had a spare weekend and figured it was probably about time...

I performed an upgrade to 10.4, and everything seemed to proceed smoothly, so I took the plunge and went for 10.10.

Disaster.

My twinview Nvidia display which had been working perfectly is now broken. On boot everything seems fine, but when X starts and the second monitor springs into life the primary winks out and switches off - almost as if its been put into an unsupported display mode.

The system seems to think there's a second monitor - the nvidia logo is split across the two screens, but it can't seem to start.

Things I've tried:

  • Swapping the monitors (one is older than the other, and its definitely the port not the actual monitor)
  • Rolling back to an old Xorg conf from prior to the upgrade
  • Installing a non-beta driver direct from Nvidia (this seems to start both monitors but then apparently stops boot and causes the second display to 'wink'. Twinview seems non-functional, both displays are mirrors)
  • Disabling EDID
  • Disabling twinview, logging in and attempting to use the Nvidia config to re-detect the monitors (second monitor is falsely detected and won't go higher than 1024x768. Selecting 'apply' causes one screen to go blank and the other to display garbage)
  • googling for about 5 hours looking for similar problems, none of the offered solutions seemed to work

I'm at a loss, and it is looking very much like I'm going to have to go through a time consuming reinstall to downgrade back to the working 10.4.

Any thoughts?

share|improve this question
    
What nvidia card do you have? There's a known bug with 8400 cards which has exactly these symptoms. Workaround is to go back to the 173 driver. –  Alistair Buxton Mar 21 '11 at 2:56
add comment

1 Answer

I used TwinView on 10.10 without problems, so I think it's just an issue with old settings.

Try deleting Xorg.conf altogether (that's okay to do, because no Xorg.conf file is default now), restarting, and then checking that your Hardware Drivers is selected on the recommended one, and setting up TwinView via the Nvidia tool once again.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.