I'm trying to upgrade by using this steps :
- Update the system via terminal ("sudo apt-get update && sudo apt-get dist-upgrade")
- Run "sudo update-manager -d" (where I hope the Update Manager should open up and tell you: New distribution release ’13.04‘ is available)
But when I did the 1st step from terminal, this happened:
>Fetched 489 kB in 49s (9,954 B/s) >Reading package lists... Done >Reading package lists... Done >Building dependency tree >Reading state information... Done >You might want to run 'apt-get -f install' to correct these. >The following packages have unmet dependencies: >libc6 : Depends: libgcc1 but it is not installed > Depends: tzdata but it is not installed >E: Unmet dependencies. Try using -f.
But when I tried to run "apt-get -f install", I got:
>E: Could not open lock file /var/lib/dpkg/lock - open (13: Permission denied) > E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?
I'll really appreciate your suggestion, thanks.
Oh... I forgot to mention that I've tried that too... and the result was:
> michael@ubuntu:~$ sudo apt-get -f install > [sudo] password for michael: > Reading package lists... Done Building dependency tree > Reading state information... Done Correcting dependencies... > Done The following extra packages will be installed: apt-utils debconf > debconf-i18n dpkg gcc-4.7-base libapt-inst1.5 libapt-pkg4.12 > libbz2-1.0 libc6 libdb5.1 libgcc1 liblocale-gettext-perl liblzma5 > libselinux1 libstdc++6 libtext-charwidth-perl libtext-iconv-perl > libtext-wrapi18n-perl perl-base tar zlib1g > Suggested packages: xz-utils debconf-doc debconf-utils whiptail dialog gnome-utils > libterm-readline-gnu-perl libgtk2-perl libnet-ldap-perl libqtgui4-perl > libqtcore4-perl apt glibc-doc locales bzip2 ncompress > The following NEW packages will be installed: apt-utils debconf debconf-i18n dpkg > libapt-inst1.5 libapt-pkg4.12 libbz2-1.0 libdb5.1 libgcc1 > liblocale-gettext-perl liblzma5 libselinux1 libstdc++6 > libtext-charwidth-perl libtext-iconv-perl libtext-wrapi18n-perl > perl-base tar zlib1g > The following packages will be upgraded: > gcc-4.7-base libc6 2 upgraded, 19 newly installed, 0 to remove and 1 > not upgraded. 2 not fully installed or removed. Need to get 0 B/11.3 > MB of archives. After this operation, 22.3 MB of additional disk space > will be used. Do you want to continue [Y/n]? > y > debconf: unable to initialize frontend: Dialog debconf: (Dialog frontend requires a > screen at least 13 lines tall and 31 columns wide.) debconf: falling > back to frontend: Readline > E: Cannot get debconf version. Is debconf installed? debconf: apt-extracttemplates failed: (Reading database... 479 files and directories currently installed.) Preparing to replace libc6:amd64 2.15-0ubuntu20.1 (using .../libc6_2.17-0ubuntu5_amd64.deb) ... debconf: unable to initialize frontend: Dialog debconf: (Dialog frontend requires a screen at least 13 lines tall and 31 columns wide.) debconf: falling back to frontend: > Readline Checking for services that may need to be restarted... > Checking init scripts... Checking for services that may need to be > restarted... Checking init scripts... Nothing to restart. dpkg: error > processing /var/cache/apt/archives/libc6_2.17-0ubuntu5_amd64.deb > (--unpack): subprocess new pre-installation script returned error > exit status 2 dpkg: regarding .../libbz2-1.0_1.0.6-4_amd64.deb > containing libbz2-1.0:amd64, pre-dependency problem: libbz2-1.0 > pre-depends on multiarch-support multiarch-support is unpacked, but > has never been configured. > > dpkg: error processing > /var/cache/apt/archives/libbz2-1.0_1.0.6-4_amd64.deb (--unpack): > pre-dependency problem - not installing libbz2-1.0:amd64 Errors were > encountered while processing: > /var/cache/apt/archives/libc6_2.17-0ubuntu5_amd64.deb > /var/cache/apt/archives/libbz2-1.0_1.0.6-4_amd64.deb > E: Sub-process > /usr/bin/dpkg returned an error code (1)