Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I downloaded virtualbox-4.2_4.2.12-84980~Ubuntu~raring_i386.deb (63.9 MB) and Oracle_VM_VirtualBox_Extension_Pack-4.2.12-84980.vbox-extpack (11.6 MB) from https://www.virtualbox.org/wiki/Linux_Downloads.

I installed VBox on my laptop (Dell 1545 Core2Duo T6400; 4 GB RAM) running Lubuntu 13.04 giving the guest OS (also Lubuntu 13.04) 1536 MB RAM and 8 GB fixed disk space.

Performance is okay but I'm having trouble with the screen size. The desktop doesn't occupy the full width of the screen as the image shows (red ellipses).

VBox screen size

I can use "scale mode" but that looks ugly as though things have been stretched horizontally.

Some reading indicates that installing Guest Addditions would help. But I can't figure out how to install it. I have /usr/share/virtualbox/VBoxGuestAdditions.iso.

I've tried to mount VBoxGuestAdditions.iso:

Mounted-iso

But when I click on Devices, Install Guest Additions, I see this window:

Force Unmount

Also puzzling is that there's an option to "force unmount" when the text above says "unable to mount".

share|improve this question
1  
Did you try to run virtualbox as sudo? For similar problems usually such thing helped me: In machine settings unmount the guest auditions and set host cd as IDE. Then try to install GA via menu of the running virtualbox machine. –  Misery Jun 21 '13 at 18:09
    
But sudo VirtualBox brings up the screen for a new VM. It doesn't see the VM existing already. –  user25656 Jun 21 '13 at 18:16
    
@vasa1 In settings for graphics in virtualbox (before you start the machine for Linux) - you can set the size of memory for graphics - with this you have enfluence on size of the virtual-display ?! - or not ?! –  dschinn1001 Jun 21 '13 at 19:03
1  
@ vasa1 @Misery VirtualBox never needs sudo, and should be never run as sudo. And this problem is independent of sudo. –  ignis Jun 21 '13 at 19:46
add comment

1 Answer

up vote 10 down vote accepted

Clicking the "Install Guest Additions" menu item just adds the iso to the virtual machine. You don't need to click it, because, in your case, the VirtualBoxGuestAdditions.iso is already attached to the virtual machine (as per the Storage tab of the virtual machine settings). It's named like that because the guest is supposed to automount the CD and autorun the installer, but I've never seen this behavior on Ubuntu, so the name is misleading in this case.

From the VirtualBox manual, Chapter 4 (Guest Additions), section "Installing the Linux Guest Additions":

Ubuntu

sudo apt-get update

sudo apt-get upgrade

sudo apt-get install dkms

Reboot your guest system in order to activate the updates and then proceed as described above:

  • Insert the VBoxGuestAdditions.iso CD file into your Linux guest's virtual CD-ROM drive [Don't do this, if the Storage tab shows it to be already attached to the virtual machine]
  • [open a terminal, ] Change to the directory where your CD-ROM drive is mounted, and execute as root:
  • sh ./VBoxLinuxAdditions.run
share|improve this answer
    
Installing virtualbox additions in Ubuntu to enable "Auto-Size Guest Display" - worked out of the box. Not so with lubuntu. However, installing the extra dkms package as you suggested, did the trick. –  Greg Woods Dec 20 '13 at 11:32
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.