Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am running Ubuntu 12.04 LTS on a partition on (I believe) an Apple Mac mini "Core i5". Everything was going well until recently. Now Ubuntu hangs during the purple splash screen, just showing endless cycling dots. I have been able to successfully boot in text only mode by changing the GRUB boot command from "quiet splash" to "text", and launched lightdm from the command line, but this is really not what I want to do every time I start up. I've looked at a lot of similar questions and tried the solutions there, such as trying to reconfigure xserver-xorg and setting GRUB to "nomodeset", but none of them worked. I would be willing to retry any of those solutions at the direction of answerers who think they know what to do to fix it.

A fun complication to all of this is that the Mac Mini doesn't have an optical drive and so I can't use a LiveCD, and requires an intense and painful process to create a Mac LiveUSB, so that is a solution of last resort.

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.