Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have been using 12.04 as a guest on my laptop for quiet some time now and it works flawlessly.

Today a colleague asked me about the 3D performance of the guest. It never came in my mind to use fancy 3D stuff on the guest, but i was interested in the results anyway, so i enabled the 3D acceleration in the VirtualBox menu for my installation and rebooted the vm.

Running glxgears gives strange warnings, plus the window with the rotating gears stays black (i posted the console output below).

Running glxgears without the 3D acceleration enabled works, i end up with ~570 FPS and no warnings.

The low FPS are not my issue here, but the black glxgears window is strange. My guess is that there is some issue with the nVidia driver of the host system? (looking at the NV suffix of the warnings)

ortang@vbox-12-04:~$ glxgears 
OpenGL Warning: glFlushVertexArrayRangeNV not found in mesa table
OpenGL Warning: glVertexArrayRangeNV not found in mesa table
OpenGL Warning: glCombinerInputNV not found in mesa table
OpenGL Warning: glCombinerOutputNV not found in mesa table
OpenGL Warning: glCombinerParameterfNV not found in mesa table
OpenGL Warning: glCombinerParameterfvNV not found in mesa table
OpenGL Warning: glCombinerParameteriNV not found in mesa table
OpenGL Warning: glCombinerParameterivNV not found in mesa table
OpenGL Warning: glFinalCombinerInputNV not found in mesa table
OpenGL Warning: glGetCombinerInputParameterfvNV not found in mesa table
OpenGL Warning: glGetCombinerInputParameterivNV not found in mesa table
OpenGL Warning: glGetCombinerOutputParameterfvNV not found in mesa table
OpenGL Warning: glGetCombinerOutputParameterivNV not found in mesa table
OpenGL Warning: glGetFinalCombinerInputParameterfvNV not found in mesa table
OpenGL Warning: glGetFinalCombinerInputParameterivNV not found in mesa table
OpenGL Warning: glDeleteFencesNV not found in mesa table
OpenGL Warning: glFinishFenceNV not found in mesa table
OpenGL Warning: glGenFencesNV not found in mesa table
OpenGL Warning: glGetFenceivNV not found in mesa table
OpenGL Warning: glIsFenceNV not found in mesa table
OpenGL Warning: glSetFenceNV not found in mesa table
OpenGL Warning: glTestFenceNV not found in mesa table
369 frames in 5.0 seconds = 73.647 FPS

The host is a Windows 7(64bit) Dell Laptop (Precision E4600) with a i7-2820QM CPU and a nVidia Quadro 2000M (driver version 311.10) graphics card.

The guest is an up to date 12.04 LTS install, with installed guest addons.

Some additional information, running the unity support test tool:

ortang@vbox-12-04:~$ /usr/lib/nux/unity_support_test -p
OpenGL Warning: glFlushVertexArrayRangeNV not found in mesa table
OpenGL Warning: glVertexArrayRangeNV not found in mesa table
OpenGL Warning: glCombinerInputNV not found in mesa table
OpenGL Warning: glCombinerOutputNV not found in mesa table
OpenGL Warning: glCombinerParameterfNV not found in mesa table
OpenGL Warning: glCombinerParameterfvNV not found in mesa table
OpenGL Warning: glCombinerParameteriNV not found in mesa table
OpenGL Warning: glCombinerParameterivNV not found in mesa table
OpenGL Warning: glFinalCombinerInputNV not found in mesa table
OpenGL Warning: glGetCombinerInputParameterfvNV not found in mesa table
OpenGL Warning: glGetCombinerInputParameterivNV not found in mesa table
OpenGL Warning: glGetCombinerOutputParameterfvNV not found in mesa table
OpenGL Warning: glGetCombinerOutputParameterivNV not found in mesa table
OpenGL Warning: glGetFinalCombinerInputParameterfvNV not found in mesa table
OpenGL Warning: glGetFinalCombinerInputParameterivNV not found in mesa table
OpenGL Warning: glDeleteFencesNV not found in mesa table
OpenGL Warning: glFinishFenceNV not found in mesa table
OpenGL Warning: glGenFencesNV not found in mesa table
OpenGL Warning: glGetFenceivNV not found in mesa table
OpenGL Warning: glIsFenceNV not found in mesa table
OpenGL Warning: glSetFenceNV not found in mesa table
OpenGL Warning: glTestFenceNV not found in mesa table
OpenGL vendor string:   Humper
OpenGL renderer string: Chromium
OpenGL version string:  2.1 Chromium 1.9

Not software rendered:    yes
Not blacklisted:          yes
GLX fbconfig:             yes
GLX texture from pixmap:  yes
GL npot or rect textures: yes
GL vertex program:        yes
GL fragment program:      yes
GL vertex buffer object:  yes
GL framebuffer object:    yes
GL version is 1.4+:       yes

Unity 3D supported:       yes

The GUI runs smooth, however i have not activated any fancy stuff (all default).

I have found some links where they report that the 3D acceleration works fine on a 12.04 guest, they even run games there with no major performance loss.

I found a similar post on stackoverflow but that was closed as off topic:

http://stackoverflow.com/questions/16287511/opengl-warnings-after-enabling-3d-acceleration-in-virtual-box-running-ubuntu-12

Any hints to solve that problem would be nice!

share|improve this question

2 Answers 2

The video drivers on the Guest Additions package are merely a proxy between the guest OS and the host video drivers (with some limitations, like 16 (modifiable) MB of VRAM). This means the same errors might pop even if the OS would run with updated NVidia Drivers (you can use the proprietary drivers -- to install them just execute the .run file from a shell) or, maybe, only WITHOUT the updated drivers.

It is possible that Windows 7 doesn't include (At least I guess it doesn't) the real NVidia Drivers, but at most compatible but less powerful ones (like those originally found on Ubuntu). If so, you have to update the HOST drivers from HERE!

share|improve this answer

Have you installed Virtualbox Guest Additions tools on the virtual machine? Once the machine is running go to the menu tab that says devices, go down to the last option on the menu and press the Insert CD with Gest Additions option, you will see a CD booting inside the OS, install the drivers and you will get better performance, hope it helps.

share|improve this answer
    
Yes i have them installed. The guest is an up to date 12.04 LTS install, with installed guest addons. –  ortang Jan 8 at 15:54

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.