Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My /boot/ sadly is full, so I cant use apt-get upgrade anymore, or similar things.

If I try to purge one of the kernels, with:

apt-get purge linux-image-3.2.0-29-generic

I get:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 linux-server : Depends: linux-headers-server (= 3.2.0.41.49) but 3.2.0.48.58 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

And nothing happens after all. I cant use apt-get -f install, since the action fails due to a full /boot/. How can I force apt-get to delete one of the images?

Thanks for the help.

share|improve this question

1 Answer 1

up vote 0 down vote accepted

Here is an older thread :

http://ubuntuforums.org/showthread.php?t=1587462

You could use tweak or synaptic for to remove some of the older kernels.

I would let at least one older kernel of your choice "alive" - cause then you are safe for to boot for sure - in case the newest kernel does not work right after update, or after being malformed somehow.

share|improve this answer
    
The problem is, I dont have a GUI, and neither synaptic or tweak installed (it's a remote server) –  user169099 Jun 21 '13 at 15:30
    
@user169099 here is a possibility how to do it from terminal: ubuntugenius.wordpress.com/2011/01/08/… –  dschinn1001 Jun 21 '13 at 16:17
    
same problem as before - it stops midway, telling me that I have dependencies. I dont get it, why cant I just force apt to remove that thing, ignoring the dependencies (that have nothing to do with the old kernels anyways, since that error comes when I try to delete ANY kernel). I cant install, I cant upgrade, I cant remove. I'm stuck - I just need to 'force' the command... –  user169099 Jun 21 '13 at 16:24
    
@user169099 You already tried: sudo apt-get autoremove ? –  dschinn1001 Jun 21 '13 at 18:58
    
same thing - I always get the same error, no matter what apt-get command I give - it always tells me that I have to try out apt-get -f install - but that command fails too, since /boot/ is full –  user169099 Jun 21 '13 at 19:28

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.