Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am a photojournalist/digital photo artist and I am getting into video editing projects I have used GIMP for my photo editing for years...

I've been doing some research on other alternatives which may have better quality results and I found Cinepaint. I found that there is a lack of .deb packages for installation into Ubuntu, so I tried 2 things.

1) downloaded from SourceForge the .rpm package and converted it to .deb with alien. It seemed to work/open properly, but I can not get it to open .jpeg, .jpg, .JPEG, .JPG, ot .TIFF files... so I wasn't able to make use/test the program...

2) downloaded the .tar.gz from SourceForge and went to compile it... I first installed the list of dependencies provided in the install file, then I ran:

sudo ./configure 

It seemed to run fine until the end and I got an error output:

=================================================================
              Configuration Results

GTK CinePaint Version 1.0-4


General dependencies:
Gtk2 toolkit                 yes    2.24.17
DnD support                  no
littleCMS                    no     !! CinePaint will not build without !!
Oyranos                      no


Plug-ins with external dependencies:
Python plug-in:              no
OpenEXR plug-in:             yes    OpenEXR 
Tiff plug-in:                yes
PNG plug-in:                 yes    libpng 1.2.49
Jpeg plug-in:                yes
Print plug-in:               no
FLTK dependent plug-ins:     no     !! CinePaint will not build without !!
Thread dependent plug-ins:   no     !! ICC Examin will not build !!
Flex dependent plug-ins:     yes    iol
=================================================================

configure: error: !!! An ERROR occured !!!
Please check the above messages to see why.
For bug reports please include the complete above output.

I'm very interested in trying this program, but because the error list doesn't give specific package names, I'm not sure how to locate/install the missing dependencies.

So I was wondering if anyone knows where to find the missing dependencies or can advise me as to how to locate them myself

or

Has any suggestions about how to get the .rpm --> .deb conversion to work properly

I usually research Ubuntu forums/askUbuntu/Google to see if there is relevant content to my problem before I post a question, however I was unable to find any content relative to Ubuntu past 8.04/.10.

I will be grateful for any suggestions or links to documentation relevant to new versions of Ubuntu or even a way to find/install a .deb package of filmgimp or glasgow or similar programs that will work on Ubuntu...

Thanks for your time

share|improve this question
    
have you tried running the autogen script before the configure script ? (it says to do so here : cinepaint.org) –  Ploutox Jun 21 '13 at 14:16
add comment

1 Answer

Regarding the packages you need, or should use, there are several, and I believe this command will pick up many of them:

sudo apt-get install liblcms-dev libtiff-dev libpng-dev libjpeg-dev libopenexr-dev libfltk1.3-dev libgutenprint-dev libxmu-dev flex

For me, at least, that got it to configure, on Ubuntu 13.04 (Raring).

This list came from looking at the allpackages link, and comparing with the stated dependencies. The allpackages link is: http://packages.ubuntu.com/raring/allpackages and for whatever version of Ubuntu you are using, you will need to adjust it.

There are at least two caveats here:

  1. This does not pick up oyranos (which apparently is used for matching colors). So if you want oyranos, then you have to arrange to build it into your system somehow.

  2. This does not cover compiling. (Per the guidelines for answering questions, I am not listing my various failures at compiling after configuration.)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.