Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

1) The boot failures on 3.08.0-19-generic appear to be due to a failure to mount the swap partition per the boot log. Though it seems odd that I still get logged-in as a user, just no Unity/menu's as opposed to just a hard blinking cursor fail.

2) The boot fails on 3.08.0-25-generic don't appear to be due to the r/o status of the filesystem as I was questioning. That is how grub mounts them prior to running initramfs. I'll boot and let the system fail, then boot to the install DVD again and see if their are errors in the boot log and dmesg. It is a hard fail when booting normally, and now the boots from recovery mode are failing hard as well.

3) Please close this thread and I'll perform further tests for another thread. Thanks for comments. I remain open to any additional things to try.

When I select "Ubuntu" from the grub menu, the PC grinds for a bit and then hangs with a black screen. I noticed that if I boot to the recovery menu the whole filesystem is read-only (ro). To get the system as read-write (r/w) (usually by enabling the network), I can then select Boot Normally, and the system starts-up fine.

I don't see any errors being reported by dmsg. However, sda6 (my boot partition) appears to get re-mounted with an error when the swap gets activated. Both UUID's are correct per blkid and fstab.

From dmesg:

[    2.508763] EXT4-fs (sda6): mounted filesystem with ordered data mode. Opts: (null)
[   15.575996] Adding 4095996k swap on /dev/sda5.  Priority:-1 extents:1 across:4095996k 
[   15.724285] EXT4-fs (sda6): re-mounted. Opts: errors=remount-ro

sudo blkid -c /dev/null:

/dev/sdb1: LABEL="HP_PAVILION" UUID="24483AB0483A809A" TYPE="ntfs" 
/dev/sdb2: LABEL="Linux_Xfer" UUID="DEA0189EA0187F69" TYPE="ntfs" 
/dev/sda1: LABEL="HP" UUID="DEA201E3A201C14F" TYPE="ntfs" 
/dev/sda4: LABEL="RECOVERY" UUID="909C42D99C42B98C" TYPE="ntfs" 
/dev/sda5: UUID="56089873-301a-42da-a79e-be2b4d3e3d72" TYPE="swap" 
/dev/sda6: UUID="c76fa243-7dec-49bb-bd8a-1628794155d1" TYPE="ext4" 
/dev/sdg: LABEL="ReadyBoost" UUID="7A26617D26613AF1" TYPE="ntfs" 
/dev/sdh5: LABEL="OnFloor" UUID="022438AF2438A815" TYPE="ntfs" 

cat /etc/fstab:

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda6 during installation
#UUID=c76fa243-7dec-49bb-bd8a-1628794155d1 /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda5 during installation
UUID=56089873-301a-42da-a79e-be2b4d3e3d72 none            swap    sw              0       0
share|improve this question
    
This is on new install from DVD of 13.04, though it has been hanging on boots since 12.04. I don't get any warnings when Vista boots from this disk though that is a different partion. gparted seems happy with the disk and all its partions. –  user169066 Jun 21 '13 at 13:25
1  
Welcome to Ask Ubuntu! Opts: errors=remount-ro just informs about this option. This is not an error. It's just a setting that if an error occurs, it should remount read-only. Can you try to start normally with the boot parameter quiet removed from the kernel command line? See this answer (section Black/purple screen after you boot Ubuntu for the first time) on how to edit kernel boot parameters from the boot screen. –  gertvdijk Jun 21 '13 at 13:35
    
Thank you very much for the help. So, I rebooted with the quiet and splash removed from the kernel command line. I edit the /etc/default/grub and updated since I always change the default boot option. Again, the system hangs with a black screen right after logging me automatically as per my installation option. –  user169066 Jun 21 '13 at 15:03
    
So, then I tried booting into the recovery menu, enabling r/w, and Normal Boot. Unlike the last several times, the system hung this time following the auto login. Prior to re-booting into 3.08.0-25-generic I did successfully install the Nvidia drivers (310) and restarted with them a couple times. I've had problems with the NV drivers since U-10, so that may be causing some of the problems. –  user169066 Jun 21 '13 at 15:15
    
So, then I tried booting to the 2.08.0-19-generic kernel (previous attempts with the 25-generic). This kernel generated an 'internal error' while starting and sent off some bug reports. Finally it got to where it showed a gradient background and an arrow cursor (suggesting X started), but Unity never started. Alt-Ctrl-Del allowed me to logoff which worked OK and I got the system bar at the top and could access an abbreviated system menu as well as login. Logging in as me and as a guest both result in the gradient/arrow but no Unity or system bar. –  user169066 Jun 21 '13 at 15:16
show 6 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.