Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to install ubiquity-frontend-gtk through Synaptic Package manager but getting following error. I even cant install through terminal

sudo apt-get install ubiquity-frontend-gtk
returned with following error
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created or been moved out of Incoming.

The following information may help to resolve the situation:
The following packages have unmet dependencies:
ubiquity-frontend-gtk : Depends: ubiquity (= 2.12.14) but 2.12.16 is to be installed
E: Unable to correct problems, you have held broken packages.

sudo aptitude install ubiquity-frontend-gtk (did not work for metoo)

a busy cat

anybody help me plz

share|improve this question
    
sudo apt-get -f update followed by sudo apt-get -f upgrade might solve your problem. –  Marc Jun 21 '13 at 13:33
    
i tried but still no luck –  UbuntuLover Jun 21 '13 at 16:03
add comment

1 Answer 1

Stolen from http://ubuntuforums.org/showthread.php?t=947124. I've followed these directions from this very post a while back. It took me a bit to find it again.

sudo apt-get update to update you list of available upgrades.

sudo apt-get autoclean to remove any partially installed packages.

sudo apt-get clean to cleal the apt cache.

sudo apt-get autoremove to remove any unneeded dependencies.

sudo dpkg --remove -force --force-remove-reinstreq broken-pakage will remove any broken package that you find in error messages.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.