Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Can somebody explain why in my Ubuntu 13.04 the facebook site and youtube site can't be opened by Chrome or Firefox. Other sites can be opened except for this two site. I really need a hand here.

result from ip addr:

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet scope host lo
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1402 qdisc pfifo_fast state UP qlen 1000
    link/ether 00:23:18:a1:c1:96 brd ff:ff:ff:ff:ff:ff
    inet brd scope global eth0
    inet6 fe80::223:18ff:fea1:c196/64 scope link 
       valid_lft forever preferred_lft forever
3: wlan0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN qlen 1000
    link/ether 40:61:86:9c:18:cf brd ff:ff:ff:ff:ff:ff

victor@victornolii:~$ ping -c 4
PING ( 56(84) bytes of data.
64 bytes from icmp_req=1 ttl=50 time=905 ms
64 bytes from icmp_req=2 ttl=50 time=2155 ms
64 bytes from icmp_req=4 ttl=50 time=1796 ms
share|improve this question
What do you mean "it cannot be opened"? Please be more specific. What is the error you get? "Connection refused", "Could not resolve hostname...", "Connection timed out", "SSL error" etc. If websites aren't reachable from any browser, this is more likely to be a networking issue than an issue with Ubuntu. – gertvdijk Jun 21 '13 at 9:22
the loading circle just keep rotating without doing anything and it doesn't tell anything regarding what error it is.. – victornolii Jun 22 '13 at 11:44
Do you have a proxy server configured? Disable that if you don't need it. Do you have IPv6, but is it failing? Provide the output of ip addr run in the terminal. Does running of a live CD change the situation? What happens if you leave the browser loading for a few minutes? It should always provide an error - just be patient! What happens if you go to https directly? E.g. What does running curl -I in the terminal give you? And how about ping -c 4 Please edit your question to provide all this new information. – gertvdijk Jun 22 '13 at 12:40
sorry to bother you @gertvdijk i'm just a newbie to ubuntu. – victornolii Jun 22 '13 at 14:28
The problem is that when you type into your browser, your internet settings include a DNS server which looks up and returns the IP address for Google, and your broweser shows you Google. Except yours don't. Somehow, your DNS request is returning a bogus value. I don't see how this can happen innocently. I would right-click on my internet connections icon, edit my connection setting to use a reliable DNS server. OpenDNS is good. It's at for the primary and for the secondary. Save and reconnect. See what happens. – Marc Jun 22 '13 at 15:25

3 Answers 3

You have DNS issues.

From the ping command, I see that your system resolves to Well, that is not Youtube or Google. No, that's an internet sevice provider in the Philippines. That's scary. Somebody is trying to be the "man in the middle" here! Be aware.

Try using Google Public DNS on your system instead. Follow the instructions in this answer on how to do that:

$ whois
% [ node-7]
% Whois data copyright terms

inetnum: -
netname:        GLOBET-PH
descr:          Globe Telecom/Innove Communication
descr:          Internet Service Provider, Makati City
country:        PH

And it has no reverse DNS (all Google servers have that!):

$ host
Host not found: 2(SERVFAIL)

In the Netherlands, it looks like this (and you should have similar results - though the IP address will be different of course):

$ whois # result of ping
NetRange: -
OriginAS:       AS15169
NetName:        GOOGLE

OrgName:        Google Inc.
OrgId:          GOGL
Address:        1600 Amphitheatre Parkway
City:           Mountain View
StateProv:      CA
PostalCode:     94043
Country:        US

$ host domain name pointer
share|improve this answer
i live here in the philippines. so it is the internet service provider that makes this? youtube channels can be opened until the video, but it won't play facebook is worse. it just open a empty page. – victornolii Jun 22 '13 at 14:38
@victornolii If this in the whois info I added is really your internet service provider, then they are pretending to be Youtube! I would not trust this connection anymore. – gertvdijk Jun 22 '13 at 14:41
yes it is.. thats the company.. but it worked before when i was using windows. can't really imagine whats the problem newbie issues haha – victornolii Jun 22 '13 at 14:47
so there is no solution then to change the internet service provider? – victornolii Jun 22 '13 at 15:15
@victornolii I've given some things to try. I can't tell from here what would be the solution - I cannot see your screen and I don't have access to your internet connection. :) Have you tried the suggested change of DNS servers? That could be your solution here. And also please include all the things you've changed on your system in your question. As you've mentioned changing MTU - what more is there you haven't told us yet? – gertvdijk Jun 22 '13 at 15:32

Try install restricted packages:

sudo apt-get install ubuntu-restricted-extras
share|improve this answer
i installed restricted packages but it still can't open those pages. – victornolii Jun 22 '13 at 11:41
This has nothing to do with a page not being able to load in a browser - this is only for addons like Adobe Flash and fonts. – gertvdijk Jun 22 '13 at 12:41

I've reached the same error. The problem was resolved after i've changed the interface's MTU to 1464. The original value was 1500.

share|improve this answer
Do you live in Philippines? – Braiam Sep 6 '13 at 4:22

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.