Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have no Audio sound, neither in speaker nor in headphones, i used to work on 12.10 but after this problem started i upgraded to 13.04 in hope that it may be solved, but it didn't. When i open sound configurations, the only option listed there is Dummy output, so i can't change it to any other option. I have already tried speech dispather and many other forums in here but none seem to work, please help me out as i am without audio here.

00:00.0 Host bridge: Intel Corporation 2nd Generation Core Processor Family DRAM Controller (rev 09)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200/2nd Generation Core Processor Family PCI Express Root Port (rev 09)
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
00:14.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB xHCI Host Controller (rev 04)
00:16.0 Communication controller: Intel Corporation 7 Series/C210 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 1 (rev c4)
00:1c.1 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 2 (rev c4)
00:1c.3 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 4 (rev c4)
00:1d.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation HM76 Express Chipset LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 7 Series Chipset Family 6-port SATA Controller [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation 7 Series/C210 Series Chipset Family SMBus Controller (rev 04)
01:00.0 VGA compatible controller: NVIDIA Corporation GF119M [GeForce 610M] (rev a1)
03:00.0 Network controller: Atheros Communications Inc. AR9485 Wireless Network Adapter (rev 01)
04:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. Device 5289 (rev 01)
04:00.2 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168 PCI Express Gigabit Ethernet controller (rev 0a)

These are the details of the error for package operation failed

perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = (unset),
LC_ALL = (unset),
LANG = "en_IN.ISO8859-1"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
 locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = (unset),
LC_ALL = (unset),
LANG = "en_IN.ISO8859-1"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = (unset),
LC_ALL = (unset),
LANG = "en_IN.ISO8859-1"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = (unset),
LC_ALL = (unset),
LANG = "en_IN.ISO8859-1"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
Selecting previously unselected package dkms.
(Reading database ... 
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 180940 files and directories currently installed.)
Unpacking dkms (from .../dkms_2.2.0.3-1.1ubuntu2_all.deb) ...
Processing triggers for man-db ...
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
  locale: Cannot set LC_ALL to default locale: No such file or directory
Setting up dkms (2.2.0.3-1.1ubuntu2) ...
Selecting previously unselected package oem-audio-hda-daily-dkms.
(Reading database ... 
 (Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
 (Reading database ... 100%
(Reading database ... 180987 files and directories currently installed.)
Unpacking oem-audio-hda-daily-dkms (from .../oem-audio-hda-daily-dkms_0.201306201243~quantal1_all.deb) ...
Setting up oem-audio-hda-daily-dkms (0.201306201243~quantal1) ...
Loading new oem-audio-hda-daily-0.201306201243~quantal1 DKMS files...
First Installation: checking all kernels...
Building only for 3.8.0-25-generic
Building for architecture x86_64
Building initial module for 3.8.0-25-generic
Error!  The dkms.conf for this module includes a BUILD_EXCLUSIVE directive which
does not match this kernel/arch.  This indicates that it should not be built.
dpkg: error processing oem-audio-hda-daily-dkms (--install):
subprocess installed post-installation script returned error exit status 9
share|improve this question
    
Please open a terminal and post the output of lspci. –  Manuel Jun 21 '13 at 6:00
    
i posted the lpsci output above... –  user2303695 Jun 21 '13 at 6:08
    
What you can try is to install newer ALSA kernel modules: Go to the ALSA launchpad and download the package: oem-audio-hda-daily-dkms* for your distribution. Then install it and reboot. –  Manuel Jun 21 '13 at 6:09
    
when i tried to install..a window poped out "Package operation failed. The installation or removal of a software package failed. I have posted the details of the error above.. –  user2303695 Jun 21 '13 at 6:18
    
You say you use 13.04. Shouldn't you download the raring package? –  Manuel Jun 21 '13 at 6:27
show 4 more comments

1 Answer

What you can try is to install newer ALSA kernel modules: Go to the ALSA launchpad and download the package: oem-audio-hda-daily-dkms* for your distribution (raring). Then install it and reboot.

  1. Open a terminal, cd into the folder you saved the package (I assume Downloads): cd ~/Downloads
  2. Install the package via sudo dpkg -i oem-audio-hda-daily-dkms_0.201306201242~raring1_all.deb
share|improve this answer
    
i installed and then even after reboot, it didn't work.. –  user2303695 Jun 21 '13 at 7:00
    
Ok, then it is not related... sorry. –  Manuel Jun 21 '13 at 10:00
    
it's ok thanks anyways for helping..!! –  user2303695 Jun 21 '13 at 17:14
    
Have you tested if it works with the LiveCD ob Ubuntu13.04? –  Manuel Jun 24 '13 at 6:05
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.