Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an AMD E2-3200 APU (integrated Radeon GPU in CPU), running Ubuntu 12.10 (generic Ubuntu image, Linux 3.5 kernel).

My ubuntu works too slow on GUI related process. I wonder what is the best to do to get better performance here?

lshw -c video shows that it uses radeon driver. ps -ef | grep compiz shows that it uses Compiz. I did metacity --replace to disable Compiz, however the GUI was not usable after executing that command (desktop and folders disappeared, window's menu and GUI related buttons disappeared).

share|improve this question
1  
Seems like Unity is pressuring your machine too much... –  Nickolas Jun 20 '13 at 20:25
add comment

2 Answers

up vote 3 down vote accepted

From your problem description I get that you're using the default Ubuntu graphical environment - Unity - which is performing poorly on your video card.

If the suggestion of installing fglrx doesn't work/provide the required performance, please read below.

If you don't necessarily want to run Unity, the best idea that comes to my mind is to try an alternate graphical environment - XFCE or LXDE - which is much lighter than Unity on graphical resources.

I run a (custom, built on my own) XFCE/LXDE version successfully on systems with Pentium 4 CPU, 512 MB RAM and integrated Intel 82865G graphics card. The Intel 82865G graphics card is a very old & poor performance video card. Oh, I should also mention I'm running as LiveUSB (which eats some additional RAM).

While you could install only the parts required to run a XFCE/LXDE session, I think it's easiest to install the full desktop experience for Xubuntu/Lubuntu. Please know there won't be a huge volume of data to be downloaded as most part of the system is already there, only specific packages will be downloaded.

You can get XFCE/Xubuntu or LXDE/Lubuntu easily by running sudo apt-get install xubuntu-desktop or sudo apt-get install lubuntu-desktop in a terminal (CTRL+ALT+T). After that, logout and login back in, and remember to change the session from Ubuntu to Xubuntu/Lubuntu at the login screen.

Good luck and let us know if this works!

share|improve this answer
    
AMD E2 APUs are modern processor/video processor combinations. They are far more powerful than your old Intel processors. There is absolutely no need to install the lightweight XFCE or even LXDE, as his pc is capable of rendering Unity without lag. Even my old Compaq NC6000 (Pentium M 1.8GHz, Radeon 9600) is able to run Unity –  R110 Jun 20 '13 at 20:24
1  
He also has the option to remove Unity, have a look here askubuntu.com/questions/6302/how-can-you-remove-unity –  Nickolas Jun 20 '13 at 20:28
    
Installing new driver did not help much, but installing Xubuntu helped a lot, thanks a lot for the help! –  Johan Elmander Jun 25 '13 at 11:10
add comment

Installing the proprietary drivers from AMD may fix slow graphics. You can install them from the Ubuntu Software Center. Search for "fglrx" and install the package. After a reboot graphics should be better.

As MiJyn commented below, it is necessary to run sudo amdconfig --initial -f after installation. To do that, you need to open a terminal (search the Dash) and paste the command. Press enter and you will be prompted to enter your password. After you did that, you can reboot safely.

Your graphics processor is fast enough to render Ubuntu Unity.

share|improve this answer
3  
Also note that you'll probably have to run sudo aticonfig --initial after installing fglrx (before rebooting) –  MiJyn Jun 20 '13 at 18:30
    
Thanks! That's a good idea, I've edited the answer. –  R110 Jun 20 '13 at 20:20
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.