Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

i bought me an edup ep-n8531 nano wireless usb stick to upgrade my netbook, which has an built-in rt3090 that causes problems.

Background: The rt3090 is working under lubuntu 13.04, but it has connection losses. I already tried different solutions, also compiling the driver myself, but nothing worked how it should. I don't want to hack my way to get wlan working anymore and bought the stick. My router is wireless n draft capable and other devices are working pretty fine with it - windows machines and android smartphones.

The stick is delivered with a driver cd for several platforms. There's also a linux driver. But the driver is a single file called '2011_0719_RT3070_RT3370_RT5370_RT5372_Linux_STA_V2.5.0.3_DPO'. How do I install it? Just put it under lib/firmware? Can anyone help me?

lsusb says the chip is an ralink rt5370. The staging driver works but has very very poor performance - only works with the router in the same room.

If the chip causes bigger problems with linux, i could use it for some old pc and just buy another stick. The edup stick was about just 7€. Could anyone recommend a good piece of linux wireless hardware?

Thanks.

share|improve this question

1 Answer 1

You will never get this old package, circa 2011, to compile properly on Ubuntu 13.04. If you want to try a newer, not older, driver, I suggest this: https://www.kernel.org/pub/linux/kernel/projects/backports/stable/v3.8.2/compat-drivers-3.8.2-2-su.tar.bz2 Obtain this package and download it to your desktop. Right-click it and select 'Extract Here.' Now open a terminal and, with an internet connection, do:

sudo apt-get install build-essential linux-headers-generic
cd Desktop/compat-drivers-3.8.2-2-su
./scripts/driver-select rt2x00
make
sudo make install

Reboot and see if performance is improved. If not, I'd get a better device.

share|improve this answer
    
Thank you. But unfortunately the quality wasn't better for stick. But perhaps it changed something for the rt3090, which is also using the rt2x00 modules. Let's see how stable the connection is. But if it's not, do you know any wlan stick without a crappy ralink chip, that properly working with linux out of the box? (should be small, nano size would be perfect) Are Broadcom chips better? –  Thorben Jun 20 '13 at 14:52
    
linuxplained.com/linux-compatible-usb-wireless-adapters-2012 There is no working USB Broadcom wireless device except one that only works sometimes with ndiswrapper. Not recommended. May we help you troubleshoot the internal device? –  chili555 Jun 20 '13 at 15:31
    
That would be nice. Actually it is working with the out-of-the-box drivers from 13.04. But there are connection losses, say every 15 minutes. With previous ubuntu versions I used a ppa with compiled drivers as workaround, but this source isn't uptodate anymore. I had also issues at university, where we use enterprise encryption with MS-CHAPv2 -> connection losses every 3 minutes, which is terribly annoying. Nothing helped. PS: can't upvote with 1 rep, but i would ;) –  Thorben Jun 20 '13 at 15:47
    
What does this tell us when it disconnects? dmesg | grep 80211 –  chili555 Jun 20 '13 at 16:09

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.