Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Last night my laptop got stuck while starting, and I (perhaps foolishly) restarted it manually. Since then (I suppose), Ubuntu seems unable to get past the login screen. I can login as guest, but every attempt to access with my username, no matter what the graphical interface, just takes me back to the login screen after a brief glimpse of some terminal lines.

So far, I tried:

  • Installing and making GDM default.
  • Doing rm ~/.Xauthority, then sudo dpkg-reconfigure lightdm run ls -lah. Output seems fine, but tried chown username:username .Xauthority nonetheless.
  • ls -ld /tmp, output seems fine, but done sudo chmod a+wt /tmp anyway.
  • chmod a+rwxt /tmp and chmod +t /tmp.
  • dpkg-reconfigure lightdm.
  • Typing cat ~/.xsession-errors only gets me a No such file or directory answer.

That's it. I don't really know what I'm doing, so I could have done some trivial mistake. Any guess? Also, I don't know if the problem is due to the forced restart or not. Right before it happened, I had some trouble upgrading.

I've gone trough the solutions suggested in Ubuntu 12.10 gets stuck in a Login Loop. Typing in terminal cat ~/.xsession-errors gives me a very long output. Would it be useful if I post it?

Sorry, the solution proposed in the duplicate didn't worked.

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.