Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

In my Ubuntu Google Chrome browser, often showing a disturbing toolbar, i am running it in command line kiosk mode.

How can i via command line mention never to show such toolbars? (after pressing X it disappear but again when page refresh it shows up, how can i disable those toolbars completely via command line launch?)

enter image description here

share|improve this question
    
Are you talking specifically about the translation toolbar? Why don't you just disable it all together from the Chrome settings and it won't disturb you ever again, even if you run Chrome from the command line? Chrome > Settings > under Language, uncheck "Offer to translate pages that aren't in a language I read". –  Alaa Jun 20 '13 at 7:00
    
NO - command line such as -disable-translate ? –  YumYumYum Jun 20 '13 at 7:02
add comment

2 Answers

up vote 2 down vote accepted

Yes, there is a --disable-translate switch that can be passed from the command line.

google-chrome --kiosk www.france.fr

enter image description here

google-chrome --disable-translate --kiosk www.france.fr

enter image description here

Note: some extra information I found is that if there's already another instance of Chrome running, running it from the command-line will show Created new window in existing browser session, which has proved to ignore the switches passed in the command, so you won't be able to pass the --disable-translate switch, so you'll need to close all instances first. However, if you want to run a new instance from the command line alongside the existing instance, you can do google-chrome --user-data-dir=$(mktemp -d) --kiosk --disable-translate (or another directory). This involves the creation of a new user data directory.

Source: the answers here and here.

There are lots of other switches available in Chrome/Chromium that can be used. You can find them listed here and here.

share|improve this answer
    
I have another strange problem –  YumYumYum Jun 20 '13 at 7:45
    
This problem is a nightmare: unix.stackexchange.com/questions/78454/… –  YumYumYum Jun 20 '13 at 7:46
1  
I don't know much about that, but I'll post a comment on your question there. –  Alaa Jun 20 '13 at 8:19
add comment

Why not disabling it? Try this.

  • In Chrome, click the Customize menu and control Google Chrome then click Options.
  • Click the Advanced category.
  • In the box Translate, uncheck the box Propose me to translate the pages that are written in a language I can not read.
share|improve this answer
    
NO - i have only SSH access, command line something like -disable-translate ? –  YumYumYum Jun 20 '13 at 7:02
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.