Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have found the answer to this but I'm posting it here in case others have the same issue and also asking if anyone has any more details ;-)

I use Firefox and Thundirbird's "Gnome Keyring Password Integration" Plugin by Guillermo Molina available here: https://addons.mozilla.org/en-US/firefox/addon/gnome-keyring-integration/

Everything has been working perfectly except that every time I start Firefox or Thunderbird I have to enter my keyring password, even if it's the same as my login password.

I could find nothing online about automatically loging in to keyrings other than the Default 'login' keyring

I was about to post a question here when I noticed the little Details drop down in the bottom of the password prompt. Looking here I found four options, the first of which was "Automatically unlock keychain at login" or something to this effect.

Setting this solved the problem, even if the keyring's password is not my login password.

Now if anyone can tell me how to change this back again now that it's set and the password prompt doesn't popup any more I'd be very grateful. :-)

share|improve this question

1 Answer 1

When you're asked to provide a keyring password and you unlock it with the mentioned checkbox checked, passwords manager adds the new record to your default keyring - you can open "Passwords and Keys" application (seahorse), select your default keyring and remove unwanted records.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.