Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I was using Ubuntu 12.10 in my VirtualBox4.2.12 on my Windows7 Host. They worked good. But when I install Ubuntu 13.04 in VirtualBox 4.2.12, the screen and display are very slow. I have followed this post <How do I resolve slow and choppy performance in virtualbox?> to enable 3D Acceleration.

Now the performance issue is resolved, but the Unity, launcher and dash are gone. I have tried to disable 3D Acceleration, the Unity can be displayed, but the performance issue come again. Please see my screenshot.

enter image description here

Is there anyone has the same issue? I have searched the answer from this site, all the answers are pointed to How do I resolve slow and choppy performance in virtualbox?

Please help me, thanks.

share|improve this question
up vote 3 down vote accepted

Well, probably the problem is in Unity's desktop environement, try installing another one... GNOME 3 is probably one of the best ones out there... To install it,

  1. Press ctrl+alt+T
  2. Then Type the following commands:

sudo add-apt-repository ppa:gnome3-team/gnome3

sudo apt-get update

sudo apt-get install gnome-shell

Then logout of your account, and click on the little Ubuntu icon right next to your login username, and select GNOME 3...

That should do, if you still have problems with performance, check for the resources you're giving to your virtual computer, (Ram, etc...)

Many people have problems with Ubuntu 13.04, so don't worry, the Ubuntu team should fix those errors soon...

share|improve this answer
Thanks that's really help. Hope they can fix those errors soon. – Chris Jun 20 '13 at 2:44
Isn't enough to: sudo apt-get install gnome-shell – kroiz Sep 30 '13 at 19:42
Those issues are still not solved even in Ubuntu 13.10 – Ladislav Mrnka Apr 7 '14 at 15:48

I have the same issue, what I do to be able to work when that happens is to log out, and log into Guest account, the log on again in my account, and Unity works again.

It's an ugly workaround but may be helpful.

To log out you will have to guess the position of the "gear" Icon on the top Right corner to click it.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.