Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

So I tried to install wine 1.5 a few times, I got 1.4 installed, and 1.6 installed oddly enough, I completely removed and purged all wine and still nothing. I installed ia32-lib and still nothing, tried installing from synaptic, ubuntu software center, and apt-get method. I get this error from apt-get in the terminal

Reading package lists... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help resolve the situation:

The following packages have unmet dependencies:
 wine1.5 : Depends: wine1.6 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

The particular windows program I want to install is confirmed working in 1.5(have it working on laptop)

share|improve this question

3 Answers 3

up vote 3 down vote accepted

To install just the ppa wine & any deps from a console

1st. remove the metapackage if installed

sudo apt-get purge wine

Then same commands whether wine is or isn't installed

sudo add-apt-repository ppa:ubuntu-wine/ppa

Finish with

sudo apt-get update && sudo apt-get install wine

If you have any concerns, you can simulate, (-s) the install by going

sudo apt-get -s install wine

If all is well just re-run without -s.

share|improve this answer

I just ended up using 1.6 version, could not get 1.5 working, but 1.6 is doing fine.

share|improve this answer

Had this same issue. Drove me crazy. Ended up running:

dpkg --add-architecture i386

Then, quick update:

apt-get Update

And it appears to be installing now.

share|improve this answer
    
I don't see how adding the i386 architecture can help. –  Braiam Aug 3 '13 at 1:22

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.