Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently installed Precise on an Intel i7-4770 machine with a HD 4600 GPU and I've unfortunately been experiencing the dreaded "flickering mouse cursor" from the beginning.

I read that supposedly using the right graphics drivers for the GPU would have a high chance of fixing the issue.

Being pretty new to the Linux graphics drivers world, I'm not sure what exactly I should be looking for. Do Linux drivers specific to the HD 4600 exist in the wild, or do I instead want something like Mesa as the "next best thing". What other options do I have?

share|improve this question
    
Are any drivers listed in "Additional Drivers"? (You can find "Additional Drivers" in the "Software Sources" application) –  Seth Jun 19 '13 at 23:14
    
Seth, there aren't any at this point. –  Alexandr Kurilin Jun 20 '13 at 4:36
add comment

3 Answers 3

up vote 3 down vote accepted

Following link points to the same issue: ubuntu 12.04 - intel hd4600 haswell graphics issue

Ubuntu 12.04 (Precise) uses older kernel, while better support of Intel HD4600 was added into later kernels. It should be solved in Ubuntu 13.04 kernel and command bellow allows to use Ubuntu 13.04 kernel in 12.04 Ubuntu.

Install Raring (13.04) kernel and x-server with following command:

sudo apt-get install linux-generic-lts-raring xserver-xorg-lts-raring

I tested this steps today on fresh install of 64bit Ubuntu Precise 12.04.2 with Intel i5-4670K processor.

Comments:

  • Link on top of this answer does not install 13.04 kernel (Raring), but only 12.10 kernel (Quantal)
  • Ubuntu Precise 12.04.2 64bit (image available for download today) already includes Quantal kernel and x-server as a default. This 12.10 kernel (Quantal) has some basic support of Haswell processors (more on this link)
share|improve this answer
    
Very interesting! Do you know approximately what kernel v. includes the necessary updates for hd4600 to be fully supported? –  Alexandr Kurilin Jul 24 '13 at 23:23
    
In this link is mentioned, that some basic support was backported by Canonical into 3.5 kernel (Quantal). Better support was according to the same source added in 3.8 kernel (Raring). First mention of Intel testing theirs drivers on HD4600 mentions kernel 3.9.5, Phoronix claims much better performance on 3.10 kernel vs. original 3.8 kernel from Ubuntu Raring. –  Jan Cejka Jul 27 '13 at 10:33
add comment

OK, since Intel drivers are open source you can't find them in additional drivers as they should be installed doing the Ubuntu installation. I'd recommend trying to install the drivers from a ppa.

Open the terminal and write:

sudo apt-add-repository ppa:ubuntu-x-swat/x-updates
sudo apt-get update 
sudo apt-get dist-upgrade

This adds a graphics repo and will(hopefully) update your drivers to the newest.

If this causes any problems then remove the repo and type this into the terminal:

sudo apt-get update 
sudo apt-get dist-upgrade
share|improve this answer
    
Mathias, I'm on Ubuntu 12.04 and that page states that support for it was dropped a while ago. Should the 13.04 version still work for me, or are there alternatives for my situation? –  Alexandr Kurilin Jun 20 '13 at 1:10
    
Thanks a lot, I'll give that a shot. –  Alexandr Kurilin Jun 20 '13 at 1:42
    
... Did it work? –  Mathias Hamza Mirza Jun 20 '13 at 2:13
    
I will let you know as soon as I have a sec to give it a try! Thanks again! –  Alexandr Kurilin Jun 20 '13 at 2:14
    
Unfortunately that doesn't seem to work. The one case where the cursor always disappears is if you place it somewhere where there is an animation, such as this page: clabs.co/projects/acme_less/infrastructure.html If I place my cursor right on the red moving graph at the bottom, it will immediately disappear. I think the screen refresh is basically overwriting the cursor somehow, which doesn't happen on static chunks of the screen. –  Alexandr Kurilin Jun 20 '13 at 4:52
show 3 more comments

LTS Enablement Stack upgrade worked well for me, I no longer have flickering issues. If you encouter this problem, try that first. It's pretty much the same solution as what user178023 linked to, except I didn't have to enable proposed updates to make it work.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.