Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am running Ubuntu 13.04 on a 2011 Dell XPS L501X laptop: Intel core i5, Nvidia Geforce GT 420M graphics card, 6gb ram, etc. I had no problems during normal computing, however, after installing and attempting to play minecraft on the machine. Extreme lag led me to investigate things, as this was not a problem with windows. I learned that the Ubuntu os does not seem to recognize my graphics card, and instead mentions Intel Ironlake graphics under my system information. After not finding any appropriate driver downloads on the Nvidia site, I followed the instructions given on http://www.noobslab.com/2012/10/install-latest-nvidia-drivers-in-ubuntu.html. After restarting my computer, I was able to log into my account, but then all that was displayed was my desktop background image. I tried unsuccessfully to fix the problem using some of the instructions provided in the comments on that site, and the end had to reinstall Ubuntu 13.04. After putting all of my documents, software, etc. back on the computer, I tried to install the nvidia drivers via the package available in the software center, once again unsuccessfully. I have now reinstalled Ubuntu 13.04 a third time, and am wondering how I can install these drivers, if there is a way, without messing up the os. I am semi-literate with Linux, and would appreciate help. Thanks!

share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

What you have is hybrid graphics. Basically, you have 2 video cards:

  • an integrated one, embedded in your i5 CPU (Intel);
  • a discrete one, namely the NVIDIA one.

This hybrid graphics solution is intented to work like this:

  • when you do basic, light graphical stuff, automatically use the integrated card to save power (and sleep the discrete card, of course);
  • when you do advanced, heavy graphical stuff, automatically use the discrete card so the job can be done properly (and sleep the integrated card, of course).

In order for this magic to happen, some special software is needed, namely the NVIDIA Optimus: http://www.nvidia.com/object/optimus_technology.html

You'll see a (not) nice note in the link above: "Optimus requires Windows 7 or later".

So, no love from NVIDIA to Linux regarding Optimus. See this for a laugh: http://www.youtube.com/watch?v=_36yNWw_07g

What happens in your case is that you ALWAYS end up using the integrated card, no matter what you do (or what NVIDIA driver you install).

What can be done:

  • some notebooks with this hybrid graphics provide a choice in BIOS that would allow you to disable the integrated card (Intel) and ALWAYS use the discrete card (NVIDIA) - you have to check your BIOS for such setting for yourself - then, you'll have only 1 active video card in your system and it will be the NVIDIA one (resulting in Linux properly identifying your video card);
  • look at the Bumblebee project: http://bumblebee-project.org/index.html

Good luck and let us know what happens!

share|improve this answer
    
Thank you very much, I have installed bumblebee successfully and everything is working well. –  Benjamin Jun 20 '13 at 15:45
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.