Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I put in the wireless LAN card into the usb port, being new to Ubuntu i'd expect something like Windows... Auto installing itself, but nothing happened.

With the card I have a disc for the wireless LAN card to install. Inside of the disc there is a folder called Linux. I'm assuming that that is how I install the driver.

Inside of that folder there are two more folders. One is which is for the driver. Inside of that is a .tar.bz2 folder and inside of that is two more folders called Module and WPA supp.

I have no idea and I did tried to search. I found a little bit of stuff but I don't think I understand. Could someone please give me the exact instructions to install the driver/files for it?

I'm using Ubuntu 10.10 and the card is a RT2070 Ralink Lan USB 11B/G 54M Wireless card 802.11.

Pastebin of dmesg: http://pastebin.com/UrFY3NSR

Representative portion in case pastebin wipes this entry:

[  234.984025] hub 1-0:1.0: Cannot enable port 8.  Maybe the USB cable is bad?
[  234.984041] hub 1-0:1.0: unable to enumerate USB device on port 8
[  235.184037] hub 5-0:1.0: unable to enumerate USB device on port 2
[  235.744031] usb 5-2: new full speed USB device using uhci_hcd and address 8
[  235.864020] usb 5-2: device descriptor read/64, error -71

Ralink also has a page for support... http://eng.ralinktech.com.tw/support.php?s=2

This is what the readme file says, but it is to complicated to understand, maybe someone can translate it so it'll be less complicated?

http://pastebin.com/hTFrhY2w

Here are all folders/file names that is in the folder for the wireless USB driver

http://pastebin.com/1y8uvyqY

share|improve this question
    
We need more hardware information to help you, can you look at this question and then edit your question adding more detail? askubuntu.com/questions/14008/… –  Jorge Castro Mar 20 '11 at 13:59
    
Alright I did. I still have no idea how to do this. Its actually a .zip folder –  kb67 Mar 21 '11 at 17:52
    
The driver has a .exe. If I installed Wine, would that work? –  kb67 Mar 21 '11 at 23:17
    
That won't work, more than likely a bunch of zip files from a website won't work either. Let me adjust your question to see if we can get better responses. –  Jorge Castro Mar 21 '11 at 23:58
    
It's a .tar.bz2 folder! Sorry for the confusing! –  kb67 Mar 23 '11 at 15:39
show 5 more comments

8 Answers

Solved over on ubuntuforums. Long and painful. Does require compiling the driver if you do it exactly according to the forum directions here.

share|improve this answer
add comment

ok. here is the general process. it works in most of the cases. copy the file_name.tar.gz folder in desktop.Then follow the code in terminal.

neal@ubuntu:~$ cd Desktop    
neal@ubuntu:~$  tar zxvf file_name.tar.gz
neal@ubuntu:~$ cd file_name
neal@ubuntu:~$ ./install.sh
share|improve this answer
add comment

You probably only need the firmware file instead of the full driver, depending on how new the card is.

Since it's not always clear what's going on, please do the following:

  • Remove your USB key
  • Open a Terminal
  • Type dmesg and hit enter. Note what the last line is.
  • Insert your USB key
  • Type dmesg again and hit enter.
  • Copy/paste the lines that are new the second time around (they'll be at the bottom) to the question.

That will help us immensely.

As for installing the driver, the vendor should have included instructions on how to install the driver on the CD. If it's meant to be a compile-it-yourself module, you're in for a bit of work but nothing insurmountable.

share|improve this answer
    
Yes a instruction but it was for windows only. here you go and I really hope you can help me out. pastebin.com/UrFY3NSR –  kb67 Mar 21 '11 at 21:59
    
[ 164.676024] hub 1-0:1.0: Cannot enable port 8. Maybe the USB cable is bad? [ 173.580049] hub 1-0:1.0: unable to enumerate USB device on port 8 # [ 173.832044] usb 1-7: new high speed USB device using ehci_hcd and address 8 –  Broam Mar 22 '11 at 14:12
    
This is...not what I wanted to see. It seems like your device isn't even being DETECTED. –  Broam Mar 22 '11 at 14:12
    
Well the lights on the device lights up. & I tested it on Windows and it works. Anything I can do? –  kb67 Mar 22 '11 at 18:07
add comment

I suggest you firstly unzip the zip folder you mention. In Linux you only have to right click the folder and choose open with archiver, this will generate a plain folder of the same name. Add to your question, any queries you have about the contents of this folder.

share|improve this answer
add comment

from your home directory, and with the tar file in that directory, run the following in a command shell:

cd RT3070_LinuxSTA_V2.3.0.1_20100208
sudo make
sudo make install
sudo mkdir /etc/Wireless/RT2870STA
sudo cp RT2870STA.dat  /etc/Wireless/RT2870STA/RT2870STA.dat
cd os/linux
sudo /sbin/ifconfig ra0 down
sudo /sbin/rmmod rt2870sta
sudo /sbin/insmod rt2870sta.ko
sudo modprobe rt2870sta

I think this should do it, although you may need to restart for it to take effect (I'm also not completely sure about that last command ... whether or not it's required). I have an rt3090 and I needed to do this process as well. With the very latest kernels, your card may work ... it's worth looking into.

  • You will need to do this process each time there is a kernel upgrade as well.
  • The Make command will probably generate a lot of warnings. These can be ignored.
  • The rmmod command may give you an error, but it can be ignored as well.
share|improve this answer
    
after sudo /sbin/ifconfig ra0 down I get no such device.. here is the log..read towars the bottom.. pastebin.com/dwmdYuQJ –  kb67 Mar 25 '11 at 23:06
    
I can understand the rmmod nor working if the module wasn't installed before. Can you do an ls of the os/linux directory? There seems to be some confusion between the version ... the whole package is names 3070, but it's doing a build for the 2870. I'm basing these steps on a manual build for a 3090. It would be nice to see which .ko file is actually being built in the os/linux directory, just to be sure. –  Nerdfest Mar 26 '11 at 5:38
    
Also, the title is RT2070. Is that correct, or is it an RT3070? –  Nerdfest Mar 26 '11 at 5:39
    
This is very confusing between the rt3070, rt2070, and the rt2870, but I think I've found the correct set of instructions for getting your card working. They're very close to the ones I have above, but correct the model numbers and add a few blacklist entries (which I need to do as well). Try this: ubuntuforums.org/showthread.php?t=1285828 –  Nerdfest Mar 26 '11 at 6:04
add comment

I had a look at your output from your dmesg, it does look like it's not being detected.

You should try lsusb also this should give you a list of usb devices. We can confirm that it's there or not.

Otherwise the installation from source code generally follow the same procedure:

1) unzip tar.gz to a folder 2) From command line go to folder 3) type: sudo ./configure 4) type: make 5) type make install

IF there are mistakes during ./configure report them and check if there's something extra to install.

share|improve this answer
    
Also, this might not help you now and feel a bit bitter but checking compatibility before buying something on linux helps preventing bad surprises. Learned the hard way and happy to share! –  ndefontenay Mar 29 '11 at 11:25
add comment

Installing NDISwrapper and loading the wireless driver into the program usually works for me on wireless sticks.

share|improve this answer
add comment

You need to extract the .tar.gz into a folder. To do that you can right click on the file and choose extract. Once the file is extracted, go into the folder, and look at the readme or install files. Follow the instructions on how to install the driver.

In most cases, once you extract the file, just press Ctrl+Alt+T on your keyboard to open Terminal. When it opens, navigate to the folder where the file got extracted, and run the commands below

sudo ./configure
sudo make
sudo make install

Where,

  • ./configure will configure the software to ensure your system has the necessary functionality and libraries to successfully compile the package.
  • make will compile all the source files into executable binaries.
  • Finally, make install will install the binaries and any supporting files into the appropriate locations.

Source:cyberciti

share|improve this answer
    
Damn, this is going to be hell. –  kb67 Mar 19 '11 at 10:18
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.