Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I did a fresh install of Ubuntu 12.04 lts on my computer.One of the first things I wanted to do was to install skype. However I could not find skype in the software center.And when I tried to install it through terminal, this was the output:

paris@Paris-pc:~$ sudo apt-get install skype
[sudo] password for paris: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package skype
paris@Paris-pc:~$

So I thought that the source for the skype package might not be enabled as a repository source for the system, so I went to software center->edit->other software tab and tried to check the box of Canonical Partners>This is the message I get:

Forbidden

You don't have permission to access /1350682854.png on this server. Apache/2.2.15 (CentOS) Server at imagebin.ubuntu-gr.org Port 80

Please help.

share|improve this question
    
Perhaps I will make a new question, as the handling of the Canonical partners repositories seems to be the core problem around this. –  Noob Doob Jun 19 '13 at 17:12
    
But if anyone has an answer plz post. –  Noob Doob Jun 19 '13 at 17:19
    
Take a look at this Post on how to install Skype. –  Mitch Jun 19 '13 at 17:22

3 Answers 3

Essentially, Skype isn't a part of the standard repository as it is a piece of commercial third-party software. I'm not 100% certain why it isn't in the Ubuntu Software Centre (it isn't there for me either)

Your best bet is to directly visit the Skype website and download it from there. The download page can be found at http://www.skype.com/en/download-skype/skype-for-computer/ . Pick your distro there (12.04 for anything >= 12.04) and then download and run the .deb file it gives you. That should be all you need to do.

share|improve this answer
    
Thank you for your reply, but this did not fully answer the question.The other half is, what about the error I get about the Canonical partners? What if I want to install another package through the center or the apt-get some time? Yes, it might be possible to install manually,but since this problem occurred I can't let it be.I had previously installed Ubuntu 12.04 about a year ago and it was in the repositories.So has anything changed since then, or is it just me who has the problem? –  Noob Doob Jun 19 '13 at 17:09
    
Please note that if you install Skype directly from the Skype web site, you are on your own, and may run into difficulties that would have been taken care of if you had installed Skype from Canonical Partners instead. –  Gunnar Hjalmarsson Jun 20 '13 at 2:43
    
As @Jez W said, you should be able to find and install a .deb file for your system from skype.com/en/download-skype/skype-for-computer and download it, it will go to your downloads. In Terminal, first run the command "cd Downloads" and then run "sudo dpkg -i skype-ubuntu-precise_4.2.0.11-1_i386.deb" Let me know how that goes for you and if you have any other questions. –  seanthewebber Jun 20 '13 at 4:08
1  
@Noob Doob I'm not overly familiar with the Partners repository (oddly, it doesn't seem to appear in my system at all). Maybe it's somehow set wrong on your computer though? Try typing the following into your terminal and see if it helps: sudo add-apt-repository "deb http://archive.canonical.com/ $(lsb_release -sc) partner"; sudo apt-get update –  Jez W Jun 20 '13 at 9:59

I'm on 13.04 now, so the way to enable Canonical Partners may differ a little. But...

Once in Ubuntu Software Centre, if I select Edit -> Software Sources... -> Other Software, a Canonical Partners option appears. If I check (or in my case uncheck) it, an authentication dialog asks for my password.

I'd say that if you can't enable Canonical Partners via the Software Centre, it's a bug. In that case I recommend that you file a bug report at Launchpad.

share|improve this answer

Thank you for your replies. This is probably a bug and it should be dealt with a bug report.I did everything you said besides manual installation, and nothing worked.Since this is a routine program, I go by the thinking of Gunnar and will stick to the supported packages, to avoid trouble and needless efforts.I will probably do a reinstall, since I had just installed Ubuntu, and see if it's fixed. Thank you again.

share|improve this answer
    
@Noob_Doob skype belongs to Microsoft - after it was sold by Apple. –  dschinn1001 Jun 20 '13 at 11:35

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.