Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

How to manually configure eth0 in Ubuntu? I don't have any DHCP server. Do I need IP address when I am just going to capture packets?

share|improve this question
3  
Will you be doing it with programming? –  Ignacio Vazquez-Abrams Mar 19 '11 at 6:33
add comment

migrated from serverfault.com Mar 19 '11 at 9:02

This question came from our site for professional system and network administrators.

3 Answers

I am not sure what you exactly mean by your question. The really manual method has been described above, but since you write you don't have DHCP, I think you rather would like to know what to do to give your box a static IP address and assign this IP address at boot time automatically. Well, here is how:

There should be a file /etc/network/interfaces. This file is read by the Ubuntu boot scripts which in turn configure the network according to that file. If you would like to know what should / could go into that file, then please type "man interfaces".

For example, my /etc/network/interfaces looks like this (comments are cut out):

auto lo
iface lo inet loopback

auto eth0
iface eth0 inet static
        address 192.168.20.20
        netmask 255.255.255.0
        network 192.168.20.0
        broadcast 192.168.20.255
        gateway 192.168.20.250

The first two lines are standard and may already look similar on your box. You may be interested especially in the rest of the file: These lines define a static network configuration to eth0 (without DHCP), and this static configuration gets active automatically on every boot.

share|improve this answer
add comment

You don't need IP address for capturing packets in promiscuous mode (when you want to capture all traffic, not just traffic destined to your computer). You can put that interface up using command

ifconfig eth0 up

This do not assign IPv4 address to interface (IPv6 local-link address is automatically assigned, if you have IPv6 enabled).

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.