Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I try to install something, there is a hang, I don't know if it's a bug or something else...

root@computer:~# apt-get install
Reading package list... Done
Building dependancy tree
Reading state information... Done
The following package has been automatiquelly installed but aren't necessary :
  libtext-glob-perl libfile-find-rule-perl libnumber-compare-perl
Please use « apt-get autoremove » to remove them
0 upgraded, 0 newly installed, 0 to remove.
Paramating rsyslog (5.8.6-1ubuntu8.3) ...
Skipping profile in /etc/apparmor.d/disable: usr.sbin.rsyslogd

And it's hanging there. I let it run for more then 15 minutes, I had to stop it using Ctrl+C).

Anyone has an idea of how to fix it and/or what may be the cause?

share|improve this question
    
Try apt-get update && apt-get install -f && apt-get autoremove post any errors. –  bodhi.zazen Jun 19 '13 at 15:58
1  
I did what you asked, there is no error. It just stop at this line : Skipping profile in /etc/apparmor.d/disable: usr.sbin.rsyslogd –  Sweq Jun 19 '13 at 18:31
1  
Yes, you were not able to remove the package because dpkg thought it was started. Now try manually run "stop rsyslog", kill that script (you dont have to wait 5 minutes.. 5 sec is enough), then proceed with uninstalling. –  Ilya Semenov Jun 21 '13 at 0:02

1 Answer 1

up vote 5 down vote accepted

Run ps afx|grep rsyslog in a different console, then:

  1. If there are traces of rsyslogd running, probably in <defunct> state, this is a bug in the upstart scripts incompatibility which has been fixed. Simply stop rsyslog, upgrade to the recent version (dpkg -r --ignore-depends rsyslog rsyslog && aptitude update && aptitude upgrade rsyslog).

  2. If there are no traces of rsyslogd running, and the only related process that hangs is start rsyslog, you need to reboot (and then perhaps continue with step 1).

share|improve this answer
    
Hi Ilya Semenov, I tried what you said, please see my edit for the log. Thx –  Sweq Jun 20 '13 at 20:46
2  
Thx! It worked! Stoping the service then suppressing the package worked very well! –  Sweq Jun 21 '13 at 14:12

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.