Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

I have a bcm4312 broadcom card. When I type iwconfig I have no wireless extensions. I know there is not a problem with my router because other devices connect fine, and my computer connects through ethernet. I had no problem connecting to wifi in 10.10 before I updated today. There is nothing about wireless at all in the network icon. I have tried downloading and installing several drivers but I'm really not sure what I'm doing. I've tried following the directions in all the questions that are similar to mine...

share|improve this question

marked as duplicate by Eric Carvalho, Radu Rădeanu, user68186, Kevin Bowen, Thomas W. Jun 19 '13 at 18:05

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1 Answer 1

For some reason, probably a copyright issue, Ubuntu had to remove the firmware for the Broadcom 43* cards from the default install. As a remedy, there are installation packages available. The one for bcm4312 is called "firmware-b43-lpphy-installer". You can install it by using the package manager front-end of your choice (I recommend synaptic), or simply by running the following on command line:

sudo apt-get install firmware-b43-lpphy-installer

After installing it, you should either reload the b43 kernel module, or simply reboot. If your computer does not automatically load the b43 module at reboot after you installed the firmware, you can try to load it manually by running (in a terminal)

sudo modprobe b43

If manual loading works, you can add a line saying "b43" to /etc/modules (you need to edit this file as root for instance by running "sudo gedit /etc/modules" on the terminal) to force Ubuntu to load it at boot.

If that doesn't work, you can also try "firmware-b43-installer".

share|improve this answer
    
Aaah thank you! I felt like I was running in circles not knowing what I was doing... networking isn't my strong point. Thank you your advice worked perfectly :) –  Ash Jun 19 '13 at 12:07

Not the answer you're looking for? Browse other questions tagged or ask your own question.