Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I would like to have different setting for various locales, so per https://help.ubuntu.com/community/Locale I edited /etc/default/locale.

However, the file does not get picked up (after rebooting) and the settings from System Settings>Langugage support are used. (i.e. running locales and cat /etc/default/locale yields very different results). How can I force the system to use the setting from /etc/default/locale?

share|improve this question
up vote 1 down vote accepted

I think you should edit ~/.profile (which overrides ~/.pam_environment) instead of /etc/default/locale to achieve what you want. Please see System Settings -> Language Support -> Help -> Advanced format settings for an example.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.