Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I bought a new laptop - Dell Inspiron 3521 which came preloaded with windows 8 and GPT partitioning. As usual, My first step after buying a new laptop is to install Ubuntu.

Hence followed this guide - Installing Ubuntu on a Pre-Installed UEFI Supported Windows 8 system and disabled secure boot (UEFI is still enabled) and installed Ubuntu 13.04

Now restarted my system. Now I don't see grub. When I selected F10 to enter boot options, I see both Ubuntu and Windows boot manager options. I am able to enter Windows but when i select Ubtuntu, it takes me to grub command line but not GUI. I even tried repairing with boot manager but still it didn't help. boot repair continues till some steps and fails saying - "Please close all your package managers and continue" . I have verified that there are no package managers running. But still it says the same. Here is my boot repair summary - http://paste.ubuntu.com/5779528/

I tried other ways as well but was not able to boot into Ubuntu.

Please help. Thanks

enter image description here

share|improve this question

1 Answer 1

I recommend you try installing my rEFInd boot manager, which will bypass GRUB. If you install it from Windows, be sure to keep the EFI drivers for x86-64, or at least the ext4fs driver. GRUB still seems to be unreliable on EFI-based computers, and fixing those problems can be very difficult, particularly if Boot Repair doesn't work.

If you prefer to stick with GRUB and Boot Repair, one thing I noticed in your output is this:

The boot of your PC is in Legacy mode. You may want to retry after changing it to EFI mode.
Do you want to continue?

Booting in EFI mode will make for a more reliable repair, although I doubt if booting in BIOS/legacy mode would cause the complete failure you've encountered. Unfortunately, how to force an EFI-mode vs. a BIOS/legacy-mode boot varies from one computer to another. Usually you can do it through the computer's own boot manager, which is usually activated by hitting a function key at boot time, but details vary greatly.

Another thing I noticed in your output is this:

chroot /mnt/boot-sav/sda7 apt-get -y --force-yes update
E: List directory /var/lib/apt/lists/partial is missing. - Acquire (2: No such file or directory)
E: Could not open lock file /var/lib/dpkg/lock - open (2: No such file or directory)
E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?

I'm not familiar enough with Boot Repair's internals to know precisely what's going on, but the last three words of this output ("are you root?") may be critical. In order to do its work, Boot Repair must be run as root. Some Linux emergency discs, such as Parted Magic and System Rescue CD, run everything as root by default. If you're using an Ubuntu disc, though, you may need to precede the Boot Repair command with sudo to launch it as root.

This message could also suggest a problem with your Ubuntu installation. It could be that something went wrong with the installation, thus causing these errors. If so, you might need to re-install Ubuntu from scratch.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.